Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] GTA V Depth Buffer problems

GTA V Depth Buffer problems 4 months 5 days ago #1

Hello!
Im having some kind of trouble with the depth buffer, when i activate the depth buffer in the game it all appears black.
I've been researching a little bit to try to fix this issue but at the time nothing worked.
I enabled the LOGARITHMIC option and also disabled the SMAA, tried to put the resolution scale to 16:9/16:10/Auto etc but nothing worked (im pretty newbie at tweaking this kind of things)
Im using this graphical mod by the way: Natural Vision
The reshade version im using right now is the 2.0
Basically i want to have depth buffer access for editing purposes and to have more freedom at the time to edit and play around with the footage.
I've seen users like @crosire that posted screenshots with the Depth Buffer enabled.

I would be pretty happy if someone can help me to fix this little issue.
Thanks!
The administrator has disabled public write access.

GTA V Depth Buffer problems 4 months 5 days ago #2

  • Elimina
  • Elimina's Avatar
  • Offline
  • ΞLIMINΛ
  • Posts: 331
  • Thank you received: 358
quirze wrote:
Hello!
Im having some kind of trouble with the depth buffer, when i activate the depth buffer in the game it all appears black.
I've been researching a little bit to try to fix this issue but at the time nothing worked.
I enabled the LOGARITHMIC option and also disabled the SMAA, tried to put the resolution scale to 16:9/16:10/Auto etc but nothing worked (im pretty newbie at tweaking this kind of things)
Im using this graphical mod by the way: Natural Vision
The reshade version im using right now is the 2.0
Basically i want to have depth buffer access for editing purposes and to have more freedom at the time to edit and play around with the footage.
I've seen users like @crosire that posted screenshots with the Depth Buffer enabled.

I would be pretty happy if someone can help me to fix this little issue.
Thanks!

When enabling the depth buffer access in GTA V, ensure that you have all in-game AA disabled (Sometimes FXAA & SMAA still work, but try it without either if you are having troubles.) Next, open the Global.cfg (ReShade/Profiles/Default/) and make sure that "RESHADE_DEPTH_INPUT_IS_REVERSED" is set to 1, and "RESHADE_DEPTH_LINEARIZATION" is set to 1 as well. You should also have it set to logarithmic.

If the linearization option is set to 0, that means that all depth buffer access is disabled. The reversed Depth Buffer option is needed for GTA V in ReShade 2.0 for the depth buffer to work properly as well.
The administrator has disabled public write access.
The following user(s) said Thank You: quirze

GTA V Depth Buffer problems 4 months 4 days ago #3

Thank you very much! We can say this is solved now!
Also im tweaking #define RESHADE_DEPTH_LINEARIZATION_FAR_PLANE to see which is the more convenient one for me

SOLVED! =)
The administrator has disabled public write access.