[SOLVED] Reshade 3.0: MXAO Witcher 3 flicker

  • Posts: 221
3 years 6 months ago - 3 years 6 months ago #1 by Sunesha
I was trying to get MXAO in Witcher 3, as I think it superior to the HBAO+ I usually use. But it flickers at all settings. I have tried to turn off diffrent stuff in the W3 graphic settings as maybe something is messing with. I tried the boundary check setting, though this setting doesnt work, when activated it turns off all MXAO.

I tried the diffrent depth settings in the pre window in Reshade 3.0. There was no low precision setting in the Reshade 3.0 settings, not that believe it would make difference in this case.

Is there something I can do from my end? Or this a known thing. I use some mods, the only one that may be culprint would be a lighting mod

A 25 FPS GIF showing how it looks from my computer

Please Log in or Create an account to join the conversation.

  • Posts: 221
3 years 6 months ago #2 by Sunesha
LOL I was just thinking. Wait Witcher 3 has a temporal antialias, maybe that screw the depth buffer.

Yes this issue can be solved by turning off Witcher 3 own post-processing anti alias. I hope not get to much creepy crawlies. But I am glad that found this out.

Please Log in or Create an account to join the conversation.

  • Posts: 3
3 years 5 months ago #3 by Techno Peter
I just found this thread with the search function. How did you get The Witcher 3 running with ReShade 3.0 at all? It always crashes for me as soon as I load a save from the main menu. It works completely fine with ReShade 2.0 tho.

Please Log in or Create an account to join the conversation.

  • Posts: 1221
3 years 5 months ago #4 by Marty McFly
I have that as well - seems like the depth buffer is "vibrating". Nothing wrong on your side mate :)

Please Log in or Create an account to join the conversation.

  • Posts: 221
3 years 5 months ago #5 by Sunesha

Marty McFly wrote: I have that as well - seems like the depth buffer is "vibrating". Nothing wrong on your side mate :)

The "good vibrations" go away if you dont use witcher 3 FXAA. Though this leads to more temporal aliasing. So yeah it is kinda win some lose some.

Please Log in or Create an account to join the conversation.

  • Posts: 221
3 years 5 months ago #6 by Sunesha

Techno Peter wrote: I just found this thread with the search function. How did you get The Witcher 3 running with ReShade 3.0 at all? It always crashes for me as soon as I load a save from the main menu. It works completely fine with ReShade 2.0 tho.

I just used the the Reshade 3 setup tool choose the dx10+ option. Worked for me, though maybe system difference. I use Windows10 pro.

Please Log in or Create an account to join the conversation.

  • Posts: 304
2 years 5 months ago #7 by MonarchX
Has anyone succeeded at running Witcher 3 with MXAO without flickering? Disabling TAA does not help and W3 looks amazing with MXAO...

Please Log in or Create an account to join the conversation.

  • Posts: 219
2 years 5 months ago - 2 years 5 months ago #8 by Uncle Crassius
Like I wrote in another topic: depth buffer is reversed instead of logarithmic, at least in the gog version. Haven't got any problems at all if I disable ingame AA.


And with slightly different settings (but same preprocessor stuff):


And since I wanted to do this for once anyway here's a short video .

Please Log in or Create an account to join the conversation.

  • Posts: 304
2 years 5 months ago #9 by MonarchX
Could you share your preset, please?

Please Log in or Create an account to join the conversation.