Welcome, Guest.
Username: Password: Remember me

TOPIC: Large FPS drop briefly.

Large FPS drop briefly. 1 year 11 months ago #1

Hi every one, lets start by me stated clearly im am not blaming Reshade for my issue in anyways nor the effects. I am new to this and still class myself as newb so im thinking i did something or am missing something .
So with that siad i am having a issue on NFS 2015 . Due to the fact it its an issue with slow down i will list the relevant PC specs .
I7 4770K oc @ 4.3
GTX 780 TI oc @ 1100mhz gpu memory @ 3600mhz
16GB of 1866 ram
Windows 7 64 bit.

effects used in my Reshade are
Lumasharpening
HighPassSharp
Clarity
Colormatrix
Colorfulness
HSV
Technicolor2
Tonemap
Vignette


when i finish a race lets say or when i go to my map or anything that takes me out of the actual in game it causes a really hard fps hit when i get back into the game play
It last a good 10 seconds before i return to playable frames. I mean it drops below 20fps each time then shoots back up and sorts its self out.
Any ideas what i might have set wrong or done ? It just started doing this and the only thing i did was try Clarity with out the numeric value but then i put them back to .5 and stuff where they were "stock". Any ideas. Fire away. thanks.
Last Edit: 1 year 11 months ago by master2g.
The administrator has disabled public write access.

Large FPS drop briefly. 1 year 11 months ago #2

Does it Reload the shaders during that time (notification at the top screen border)? If so, that's to be expected. The loading briefly causes the game to stutter, since the shader compilation and texture creation blocks the game from rendering.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: master2g

Large FPS drop briefly. 1 year 11 months ago #3

Well it sure acts like it is reloading but that's the mystery as the header at top screen doesn't show Reshade reloading. Its only when you complete a race it goes to a screen and shows results and such then it returns to in game play . Now it only happens like 3 out of 5 times when i am being taking out of game play then put back in via menu or game info screens like results or maps for instance. I thought maybe i had to many effects / shaders in the load list so i remove from the shaders folder any that i wasn't using to speed up load times at game start. Start the game it is now instant. I only run these shaders in this exact order.

LumaSharpen
HighPassSharpen
Clarity
Technicolor2
ColorMatrix
Deband
HSV_Tech
Colorfulness
Tonemap
Vigntte

I was thinking , i found a post ( reshade.me/forum/shader-presentation/237...shade?start=20#18064 ) that had HSV typed out so i copy and pasted the entire code onto a new txt file , renamed the extension from txt to fx and placed it into the shaders folder that reshade reads. Yet when i load the game it reads this HSV file and everything else and is loading instantly . Is it possible the way i did the file for HSV be causing issues in game. ? If i hit scroll lock and turn off reshade when i get that massive fps hit it stops right o way and returns to normal for this games fps . I dont think its my card or drivers as cycling Resahde off fixes it instantly. Its the oddest thing. :huh:
Last Edit: 1 year 11 months ago by master2g.
The administrator has disabled public write access.

Large FPS drop briefly. 1 year 11 months ago #4

Strange. I doubt you are at fault here with the HSV thing, ReShade would have told you if you made a mistake and it should never cause stuttering.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: master2g

Large FPS drop briefly. 1 year 11 months ago #5

Yea I always seem to get the weird issues lol. I am going to monitor cpu, gpu and system ram and see if they are getting hit hard during the slow down. It calls for 4gb of vram minimum and i only have 3 . Plus im going to "repair' the game via the origin client and see if that solves it as well. .I will work away at it and keep you posted. Once i get it figured out i will close the post. Thanks :)
The administrator has disabled public write access.

Large FPS drop briefly. 1 year 11 months ago #6

No cpu, gpu or memory hit when the slow down happens. So it isn't that. I lose half of what i got on screen for fps. so if i am at say 35 then it pretty much drops to 15 or so. Now i did find that HBAO was on and i can run the game at 2560 x 1600 maxed except that as to be on SSAO . That HBAO setting takes away those extra 7 fps i need to run Reshade. So i put it back and check everything else and will try that as it "seems" to be ok for now. Oh and i repaired the game via Origin as well. I am thinking it is just a by product of low VRAM and the game being an online game possibly. I will keep watching and see if it goes into fps drop again.
The administrator has disabled public write access.

Large FPS drop briefly. 1 year 11 months ago #7

:huh: and its back.....I watched all cpu , gpu and memory numbers in real time during the slow down and nothing is changing from its normal "regular" values. Its is not a exact time thing and it can be alert 1 hour or 15 minutes. Now i have noticed the VRAM is maxed or close when this happens , but when i hit scroll lock and the game jumps back up to normal fps with vram still maxed. Now get this...when i get the sudden 15 fps drop i will deactivate reshade and it goes away, reactivate it and down goes the fps. For about 30 seconds or so resahe will reduce my fps every time i activate it. wait 30 seconds roughly then turn it on and now it doesn't effect fps. Oh i hear you its indeed the oddest thing. I got a cpu spike to 100 % a few time this happened but that was only because i went into performance monitor and seen the spike recorded there. Lately I have lost connection to EAs server more then once and the game has CTD a few times as well. Could be server related i dont know. I am at a lost to why its doing this. Its never a simple deal with my luck ...stupid luck. :( . Any hew just an update and i will keep trying to crack this issue.
The administrator has disabled public write access.