Welcome, Guest.
Username: Password: Remember me

TOPIC: How to use LUT Shader?

How to use LUT Shader? 1 year 10 months ago #1

I have some 3D LUT"s, i tried to put him on Reshade, but i don"t know how to do that. Please, I need to convert my LUT to PNG or what? Is the best color correction filter, but i don"t know how to use. :(
[ Texture | Graphics ]
The administrator has disabled public write access.

How to use LUT Shader? 1 year 10 months ago #2

1st: ReShade uses 3d luts. Not HALD luts or anything else. 3d luts consist of a single row of gradient squares.


2nd: Put the lut file into your textures folder.


3rd: Add these to your preprocessor definitions:

// NON-GUI LUT settings
fLUT_TextureName="lut.png" //change to the filename of the lut you want. It *might* have to be a png
fLUT_TileSizeXY=32 //change to the size of each individual square in pixels
fLUT_TileAmount=32 //change to the amount of squares
The administrator has disabled public write access.
The following user(s) said Thank You: Insomnia

How to use LUT Shader? 1 year 10 months ago #3

I did what you said FierySwordsman but I must be doing something wrong cuz nothing happens on screen if I enable LUT and tweak it. :/
The administrator has disabled public write access.

How to use LUT Shader? 1 year 10 months ago #4

You shouldn't have to 'tweak it'. All of the changes should be made via the lut file.

The default 'lut.png' is a neutral lut. IE, none of the colors are changed. You'll have to bring it into something like GIMP or Photoshop along with a few in-game screenshots and make some color adjustments to it.
The administrator has disabled public write access.

How to use LUT Shader? 1 year 10 months ago #5

FierySwordswoman wrote:
You shouldn't have to 'tweak it'. All of the changes should be made via the lut file.

The default 'lut.png' is a neutral lut. IE, none of the colors are changed. You'll have to bring it into something like GIMP or Photoshop along with a few in-game screenshots and make some color adjustments to it.

Oh...lol. I see now. Thanks! :)
The administrator has disabled public write access.