Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] MXAO - Flip Depth Buffer - Unturned

MXAO - Flip Depth Buffer - Unturned 1 year 3 months ago #1

So, I was configuring some shaders for Unturned recently. While working with MXAO, I noticed some severe issues with its functionality. First of all, when the game's internal TAA is enabled, the MXAO has no apparent effect at all. However, I suspect that this is due to a fundamental conflict and cannot be resolved. Secondly, with the TAA disabled, the MXAO results in strange inverted shadows of all of the objects., as shown at this link (having trouble with the embed): http://imgur.com/r5wypMy
I was reading some other forum topics, and I noticed that one solution that was commonly needed for Unity games was to flip the depth buffer. How would I go about doing this?
Last Edit: 1 year 3 months ago by VIXIVIXIV.
The administrator has disabled public write access.

MXAO - Flip Depth Buffer - Unturned 1 year 3 months ago #2

I answering from my phone so bear with me :)

If you open up Reshade with Shift+F2. Go to the second tab. There will be a square called preprocessor. There is different text already entered. They are all set to "0", which means that they are not active. There should be a text concerning flipping the depth buffer up side down. Once again sorry I don't have exact phrase. But I think it says upside down or something familiar. Change the "0" to "1". Goto the first tab. On the bottom left corner click "Reload".

If this wasn't the correct option, there is 4 of them. Just a change them "1" and try to get right option and press reloaad
The administrator has disabled public write access.

MXAO - Flip Depth Buffer - Unturned 1 year 3 months ago #3

The administrator has disabled public write access.
The following user(s) said Thank You: VIXIVIXIV

MXAO - Flip Depth Buffer - Unturned 1 year 3 months ago #4

FierySwordswoman wrote: Alright, didn't notice that section of the options. Messed around with those a little, and now I can say that (for the most part) it's working. The grass is acting a little weird, probably because it doesn't really have a depth and is a two-dimensional object, but that can't be fixed generically. Thanks for the help!
The administrator has disabled public write access.