Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade thinks Res. is lower than it is (DOF)

Reshade thinks Res. is lower than it is (DOF) 8 months 2 weeks ago #1

Hello,
im actually new to reshade, but when trying it out on Rocket League, it doesnt realy seem to work right. imgur.com/a/7VeGF
I dont think thisis normal, i tried everything. Im running at 900p borderless windowed mode, but its also in 1080p full- screen/windowed
This "issue" was there since the beginning, i didnt change any settings at all.
The administrator has disabled public write access.

Reshade thinks Res. is lower than it is (DOF) 8 months 2 weeks ago #2

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 983
  • Thank you received: 980
This looks almost as if the depth buffer resolution is scaled somehow o.O

to workaround this, find lines 356 and 370 in DOF.fx and change them like shown below.
// float scenedepth = ReShade::GetLinearizedDepth(coords); //original
float scenedepth = ReShade::GetLinearizedDepth(coords * SCALÌNG);
//scenefocus += ReShade::GetLinearizedDepth(coords * DOF_FOCUSRADIUS + focusPoint);//original
scenefocus += ReShade::GetLinearizedDepth((coords * DOF_FOCUSRADIUS + focusPoint) * SCALING);

add

#define SCALING 0.85

to the very top of the file. Then tweak that parameter until the placement of the blur looks correct. I tried to get the value correct by measuring the area of your screenshot but you might need to raise it by 0.001 or so.
Last Edit: 8 months 2 weeks ago by Marty McFly.
The administrator has disabled public write access.

Reshade thinks Res. is lower than it is (DOF) 8 months 2 weeks ago #3

Hey, first of thank you for the quick reply, and yes, it worked, thank you very much :lol:
BUT, the first time i tried it the error log showed up that there is an unknown parameter. I searched for it and u guess you chose to use an Ì instead of an I in the first
SCALÌNG ;)
i fixed it and now it works. But sadly, other shaders like "MXAO" and more are still broken ._.
guess i can use the same thing as you said with these files, but a universal fix would be better i think....
as i said, im not a "pro" in stuff like that so i hope you can help me with that again :blink:
The administrator has disabled public write access.

Reshade thinks Res. is lower than it is (DOF) 8 months 2 weeks ago #4

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 983
  • Thank you received: 980
Well, you could patch the linearizedepth function in ReShade.fxh directly, so it'll apply on every shader that uses depth.
Remove the stuff above from DoF.fx, open the ReShade.fxh and add the scaling part like this:

#define SCALING 0.85
// Helper functions
float GetLinearizedDepth(float2 texcoord)
{
texcoord *= SCALING;
#if RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN
texcoord.y = 1.0 - texcoord.y;
#endif
The administrator has disabled public write access.