Welcome, Guest.
Username: Password: Remember me

TOPIC: DOF not working in Resident Evil: Revelations

DOF not working in Resident Evil: Revelations 7 months 4 weeks ago #1

Hello,
does anybody know how to get any kind of DOF working in Resident Evil Revelations?
I tried to get it working for hours, but couldnt figure it out.
According to the games list it runs perfect, and all the other effects I use do work, just
not any DOF. (running Reshade 3.1.1)
The displaydepth.fx just shows the whole screen in white, so I guess there is no access
to the depth buffer, if I understand correctly.
So is there any kind of workaround for this?
Any help would be highly appreciated.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 4 weeks ago #2

It's been a long time since I played that game but depth of field worked when I tried it. Make sure ALL in-game anti-aliasing is disabled or else you won't get depth buffer access.
The administrator has disabled public write access.
The following user(s) said Thank You: Noir

DOF not working in Resident Evil: Revelations 7 months 4 weeks ago #3

@robgrab, thanks for the reply.
I just tried it out again, disabling the gameengines' AA, but DOF still wont work.
It's not even MSAA but only FXAA, but it makes no difference, disabling it.
There isn't also any other AA enabled (thorugh ReShade or NVidia Control Panel).
I don't get it.
Is there anything else I can try to get the DOF working with this game?
Last Edit: 7 months 4 weeks ago by Noir.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #4

The last time I tried it I was using Reshade 1.? So unless something broke along the way I don't know what else it could be. My biggest problem with that game was getting a 21:9 aspect ratio to work. I had to use a program called Widescreen Fixer and toggle a key at just the right moment or else it wouldn't work, or worse, just crash.
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #5

that widescreen fix sounds exhausting.
I'm also thinking about getting a 21:9 monitor, its just sad that so few games support it without any external fixes.

as for the DOF, I tried reshade 1.0 but it still doesn't give me any depth buffer access.
the display depth is still just a full white screen. So DOF only works as a kind of blur on the whole picture.

I also put my computer offline and disabled that re.net thing ingame, as to not raise any netcode, that in v3.? would disable
DOF, as I understood it. But then it should've worked with v1.0 I guess.

Hm, odd.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #6

Okay. I reinstalled the game to make sure it still works and it DOES.

Here's proof.
Warning: Spoiler! [ Click to expand ]


DisplayDepth
Warning: Spoiler! [ Click to expand ]


AO using MXAO
Warning: Spoiler! [ Click to expand ]


The SOLUTION was going to Settings and changing:
RESHADE_DEPTH_INPUT_IS_REVERSED=1
to
RESHADE_DEPTH_INPUT_IS_REVERSED=0

This was just a quick and dirty test to see if it would work. It hasn't been fine tuned "looks-wise" but here's the .ini file if you want to try my WIP preset.
CLICK ME

BTW I'm using the LightDoF shader here for depth of field and I REALLY like the quality and ease of configuration. It gave me the least trouble of all the other DOF shaders. I'd love to see DOF simplified in future Reshade versions. It's overly complicated for most people (including myself). :)
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.
The following user(s) said Thank You: Noir

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #7

Hey Robgrab,
that are some beautiful settings!!! kudos!
and thanks for all the effort in solving this!
I really appreciate it.

sadly, I can't get it to work.
I put RESHADE_DEPTH_INPUT_IS_REVERSED=0 in the settings.
Now the displaydepth.fx shows me a black screen (instead of a white screen),
but still no depth buffer access.

I reinstalled reshade (3.1.1) in the re:rev directory.
used your ini file. disabled steam overlay and AA ingame.
..but its still not working.
most of the other effects from your ini work. except MXAO and DOF
(which I guess both need depth buffer access).

running on win7, gtx970, i7-2600, 16gb ram, game installed on ssd.
I'm running a 16:10 1920x1200 resolution if that is somehow important.
I.. don't.. understand.. this! madness! why?

here's my d3d9.log if that helps.
Last Edit: 7 months 3 weeks ago by Noir.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #8

You don't have any overlays running in the background do you, like FRAPS, MSI Afterburner, Steam Overlay etc.? You're going to have to rely on Crosire to decipher logs. That's well beyond my area of expertise. All I know is it works perfectly for me. PLUS I finally got the widescreen to work and slightly increased the FOV! It's way less claustrophobic now. Not bad for a port of a Nintendo DS game.

Warning: Spoiler! [ Click to expand ]

Warning: Spoiler! [ Click to expand ]

Warning: Spoiler! [ Click to expand ]

Warning: Spoiler! [ Click to expand ]
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #9

no overlays running afaik. disabled steam overlay, as this was the only overlay I could think of.
no other stuff installed.
thing is, the reshade dof works in resident evil 5 without any problems.
it's only this one game it seems, that doesn't get the depth buffer access on my system.
which really is a shame, cause those new screens of you do look beautiful.
well anyway thanks for the help and happy that you got it working on your end :)
you definitely should upload your settings to the database!
(btw which reshade version are you running?)
have a nice weekend.
Last Edit: 7 months 3 weeks ago by Noir.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #10

hooray!!!
I got the depth buffer access working.
Warning: Spoiler! [ Click to expand ]


I'm running at 1920x1200px on a 16:10 monitor.
After I changed the resolution from 1920x1200 to 1920x1080 I suddenly got depth buffer access.
MXAO works as well now.
Kinda strange, cause in RE5 it worked, while running 1920x1200, but not here.

but sadly now the image is stretched, i.e. the 1920x1080 pixels are stretched to fit 1920x1080 which is really
not that pleasant to watch. Like watching a movie with the wrong aspect ratio enabled.

when I played in 1920x1200 it displayed the image correctly in 16:9 with black bars on top n bottom.
But then I had no depth buffer access.

Do you think that tool for widescreen and fov could help me with that?
And if so, how is it called?
Thanks again for all the patience.

EDIT:
So, I just changed the systems resolution to 1920x1080 via the control panel.
then the game displays correctly.
and change it back after playing. that seems to be the quickest solution right now i guess.

just two more questions, for the FOV did you use widescreenfixer?
and would you maybe share your settings from which your last screenshots were made,
that would be really really nice.

thanks again and have a nice weekend.
Last Edit: 7 months 3 weeks ago by Noir.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #11

Congrats! Hmm... The only thing I can of is the black bars being added were "technically" an overlay, which might've been blocking access to the depth buffer. Yes, I'm using Widescreen Fixer and I don't see why you wouldn't be able to use it just to increase the FOV.

As for my preset, I combined most of the effects into a single LUT for simplicity sake.
Warning: Spoiler! [ Click to expand ]

HERE is the lut.png file you'll need to put in the Reshade Textures folder.

WARNING First you'll need to crop the image in a photo editor to be exactly 1024x32 (just the colored area). Basically crop out the white portion of the image and then save it as "lut.png." Flickr wouldn't let me upload a 1024x32 pixel png file.

Here is a link to the actual the preset.
CLICK ME
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.
The following user(s) said Thank You: Noir

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #12

Nice!!!
thank you very much!
your settings look really great.
played for an hour in awe of the nice graphics.

have not tested the widescreenfixer yet, but will get to that later.

so, thanks again for all your time.
cheers to you and enjoy the rest of your weekend!
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #13

No problem. With all this tweaking you've got me going through the campaign again on New Game+. If you ever want to play some Raid Mode coop my Steam username is also robgrab.

Also, I keep coming across areas where the DoF really gives some nice separation. Like this shot here:
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #14

nice picture!
yeah, those settings with dof n all really make the game shine.

btw, do you downsample or something?
cause your screens always look a bit more.. hm.. kinda sharp n more detailed.

Warning: Spoiler! [ Click to expand ]

Warning: Spoiler! [ Click to expand ]

Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

DOF not working in Resident Evil: Revelations 7 months 3 weeks ago #15

Well, it's three things.

1ST
I'm using a new luma sharpen shader:

FilmicAnamorphSharpen

It's a depth-based luma sharpen shader written by user Fu-Bama. It's much nicer quality than most of the other sharpen shaders plus it's depth based so it doesn't sharpen things in the distance (unless you want it to) which makes it perfect for use with DoF.

2ND
The native resolution of my monitor is 3440x1440 so my screenshots are uncompressed PNG files captured at that resolution. I scale them down to JPGs at either 2560x1080 or 1920x1080 before I upload them so they'll load faster on message boards. I think the original uncompressed screenshots are 71MB vs less than 1MB for the downscaled JPG.

3RD
I adjusted the DoF values to push the focus point further out which makes more of the screen in focus or "sharp." Based on your screenshots it looks like your character isn't in focus. You'll need to adjust your DoF settings for whatever resolution you're running. My settings are all optimized for 3440x1440.

HERE is my updated preset.
Last Edit: 7 months 3 weeks ago by robgrab.
The administrator has disabled public write access.