GTA 4 starts flickering once I activate an effect

  • Posts: 4
2 years 3 months ago - 2 years 3 months ago #1 by Bad Actor
I have some severe issues with my GTA 4 (1.0.8.0) and getting Reshade to run with it.

First I've tried the old SweetFX 1.5.1 and ReShade 2.0.3/SweetFX 2.0 but both had the same issue. As soon as the game loads up, the screen starts to flicker and it looks like the injector tries to activate the effects multiple times (very rapidly).
With the recent Reshade 3.2.2 everything works fine until I try to enable an effect in the menu. The game also starts to flicker and stutter in the same way.

Does anyone here have the same issue or knows a possible solution? I would be very grateful.

Please Log in or Create an account to join the conversation.

  • Posts: 29
2 years 3 months ago #2 by Androll
Try launching it through steam, end enable steam overlay fps display. Steam overlay with fps counter fixes similar reshade issues i have.

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 years 3 months ago #3 by Bad Actor
I only own the retail/CD version of the game.

Please Log in or Create an account to join the conversation.

  • Posts: 29
2 years 3 months ago #4 by Androll
Me too! Add it to steam as non steam game.

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 years 3 months ago #5 by Bad Actor

Androll wrote: Me too! Add it to steam as non steam game.


I have but I couldn't find a way to enable the overlay for non-steam games.

Please Log in or Create an account to join the conversation.

  • Posts: 29
2 years 3 months ago - 2 years 3 months ago #6 by Androll
Check here; Steam - Settings and look under In-Game category. Mark everything like in my scrn.

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 years 3 months ago #7 by Bad Actor
I know how to enable the overlay but it just doesn't work with non-steam games.

Please Log in or Create an account to join the conversation.

  • Posts: 29
2 years 3 months ago - 2 years 3 months ago #8 by Androll
Did you mean that overlay fails with all added non-steam games?
If so, try to diagnose because you can have some more deeper problems with your OS than Reshade alone.
Disable other overlays, fps measurement tools, fraps, afterburner, reshade etc.
Purge and reinstall gfx drivers using DDU www.guru3d.com/files-details/display-dri...taller-download.html and try again.
Remember, to add GTA IV as non-steam game you MUST point steam to the correct exe (launchgtaiv.exe)

OR if you want simpler solution, just use some older gpu drivers. For me this worked too, but i'm an "update or don't use" type guy, so i sticked to overlay method.

Please Log in or Create an account to join the conversation.

  • Posts: 8
4 months 1 day ago - 4 months 1 day ago #9 by deton244
I closed Afterburner entirely, disabled Radeon Overlay, and still nothing.
I cannot run the game via Steam on my version of the game, since it only turns on Rockstar Launcher, and just clicking play there, this Steam FPS counter is not visible.

Boulotaur2024.Injector_CeeJay.dks.1.5.1.ChromaticAberration.7z causes crash on start (Windows 10).

Reshade 4.5.4 and 3.2.2 still has the issue.

Flickering stops when you press Home to show Social Club overlay. Sadly, Social Club overlay cannot be disabled in R* version.

Possibly, downgrading the game to 1.0.4.0 version may help.

Please Log in or Create an account to join the conversation.