CEL Shader not working properly wit PoE.

  • Posts: 35
5 years 1 month ago #1 by blackdragonbird
Hi guys,

I got this bug when activating the CEL Shader in PoE:



I noted that when certain spells and lighting happens, the 3D characters get some king off cool cell shading in it, and thought that the Framework would have something to make it permanent, but seems that it's not the case. The shader is getting applied upside down and the line is very thick and is applied only in the contour of 3D model, not in the internal details.

Any way to make it at least work in the right orientation, and maybe get a very fine line?

:)

Please Log in or Create an account to join the conversation.

  • Posts: 3723
5 years 1 month ago #2 by crosire
The depthbuffer is upside down and needs to be flipped in the shader first.

Please Log in or Create an account to join the conversation.

  • Posts: 35
5 years 1 month ago #3 by blackdragonbird
Thanks, but how I can do this? There are a simple option to do it or I need to change many lines of code?

Please Log in or Create an account to join the conversation.

  • Posts: 3723
5 years 1 month ago #4 by crosire
Asuming you use the Cel shader from the framework, changing lines 27/28 in "ReShade\CustomFX\Cel.h" to this should to the trick =):
float deltax = linearlizeDepth(tex2D(RFX_depthColor, float2((texcoord.x + px), 1 - texcoord.y)).x) - linearlizeDepth(tex2D(RFX_depthColor, float2((texcoord.x - px), 1 - texcoord.y)).x),
      deltay = linearlizeDepth(tex2D(RFX_depthColor, float2(texcoord.x, 1 - (texcoord.y + py))).x) - linearlizeDepth(tex2D(RFX_depthColor, float2(texcoord.x, 1 - (texcoord.y - py))).x);	

Please Log in or Create an account to join the conversation.

  • Posts: 35
5 years 1 month ago #5 by blackdragonbird
Changed the values but nothing happened, no more outlines.

Seems the last patch changed something in the way the game renders, because I don't get the outlines anymore, even after replacing the original files for the CEL shader, basically no more outlines not even upside down, but the effects from sweetfx are still working normally. :(

Please Log in or Create an account to join the conversation.

  • Posts: 35
5 years 1 month ago #6 by blackdragonbird
Downloaded the 17.1 version and the shader seems to be working, but only in some maps and not properly:





Any advice or it is something that can't be corrected?

Please Log in or Create an account to join the conversation.