Welcome, Guest.
Username: Password: Remember me

TOPIC: Dark Souls 2 Scholar of the first sin depth buffer

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #1

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Hello, I was trying to use Reshade with the new version of DS2, this one is DX11 unlike the original version. The Depth Buffer doesnt seem to work, I got a black screen when I activate it
Is it doomed or is there a possibility to make it work in the future ? :whistle:
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #2

I'm having a similar problem with it on Windows 8.1. It compiles successfully, starts up and then the screen turns white and the software crashes.

i7 4700HQ
GTX 980m
Win 8.1 Pro 64-bit
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #3

Apart from being a middle finger to the PC fan base....
There is DX11 but no depth buffer.. I am no expert but it might be possible to get it working, best bet ask one of the vets on here, or ask Crosire
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #4

  • Wicked Sick
  • Wicked Sick's Avatar
  • Offline
  • Die young or suffer (Forgive my poor English)
  • Posts: 360
  • Thank you received: 105
I had some problem with DS2SoTFS some time ago, running the .exe as administrator solved my issue.
Finding relief somewhere between a tree's branch and its shade.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #5

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
To be clear Reshade works with the game, it's the Depth Buffer which doesn't, and it is necessary to make DoF and AO works if I understood correctly

Btw I think I didn't post in the right section, I wanted to post the subject into the request section of the forum :pinch: maybe an admin can move it ?
Last Edit: 1 year 7 months ago by foudelou.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #6

  • JBeckman
  • JBeckman's Avatar
  • Offline
  • Posts: 163
  • Thank you received: 36
At a guess setting Steam to offline mode or blocking the incoming connection via firewall should force the game to also start offline which should get ReShade to OK the depth buffer since no network traffic should be logged then though it will of course also kill all online play in the game.
(All content will still be available but player invasions and such will not occur as the game can't connect to the master server or how to say.)
The administrator has disabled public write access.
The following user(s) said Thank You: Wicked Sick

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #7

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
I tested and it still doesnt work
What's the relation between depth buffer and the online anyway ? :o
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 1 year 7 months ago #8

  • JBeckman
  • JBeckman's Avatar
  • Offline
  • Posts: 163
  • Thank you received: 36
foudelou wrote:
I tested and it still doesnt work
What's the relation between depth buffer and the online anyway ? :o

If ReShade detects network traffic activity (I think it's just a simple check, nothing gets logged or such.) it will disable depth buffer access to prevent people from utilizing it to create effects that could aid in cheating, removing fog for example. :)

Only way around this is to make the game start in offline mode and play without the online component.
(Unsure if there's a command line parameter for this or if putting Steam in offline mode is enough, I blocked incoming traffic via the Windows firewall although just disconnecting the ethernet cable should work just as well.)
Last Edit: 1 year 7 months ago by JBeckman.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #9

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
I retry to play the game with post process and even by deactivating the network or playing as administrator I don't have the main effects AO & DoF ... I really don't know what the problem is, I'm not even on the same OS as before
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #10

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
I don't understand because it obviously works for some people : sfx.thelazy.net/games/screenshot/22519/
sfx.thelazy.net/games/screenshot/31869/
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #11

Are you using driver-level antialiasing perchance? Reshade and driver AA don't play well with each other, it is known.

EDIT: Ah, you answered that on the other thread, ok. Unfortunately nothing else comes to mind.
Last Edit: 11 months 3 weeks ago by SpinelessJelly.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #12

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Yep, I really have no idea either.. I installed the last drivers and deleted my profile, I disabled F.lux in case, tried many reshade/reshade with sweetfx/master effect alone/etc .. manual install, mediator install, tried with administrator rights, without, with steam overlay, without .. I can't get Z buffer although the others effects works (colorimetry, sharpen etc)

For info : w10 64 bits, GTX 970, 2500k
Last Edit: 11 months 3 weeks ago by foudelou.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #13

  • piltrafus
  • piltrafus's Avatar
  • Offline
  • Posts: 73
  • Thank you received: 15
try other resolutions. I've seen reshade depth working on some games only at specific resolutions. If you use DSR try a 4x resolution.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #14

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Thank you but still no success :p
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #15

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Problem solved : Z buffer only works in 16/9 ratio and my screen is 16/10 .. so I can have dof / AO but the image is vertically stretched :o
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #16

  • piltrafus
  • piltrafus's Avatar
  • Offline
  • Posts: 73
  • Thank you received: 15
I told you :)
You should create a 16/9 custom resolution on your nvidia control panel. And then make sure that you have "no scaling" as the scaling option. You can play then in a 16/9 resolution with black bars at the top and bottom. and no distortion.
The administrator has disabled public write access.
The following user(s) said Thank You: foudelou

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #17

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1


Thank you ! :kiss:
Last Edit: 11 months 3 weeks ago by foudelou.
The administrator has disabled public write access.

Dark Souls 2 Scholar of the first sin 11 months 3 weeks ago #18

  • piltrafus
  • piltrafus's Avatar
  • Offline
  • Posts: 73
  • Thank you received: 15
The administrator has disabled public write access.