Welcome, Guest.
Username: Password: Remember me

TOPIC: DOF Autofocus not working !! Prepar3D

DOF Autofocus not working !! Prepar3D 1 year 7 months ago #1

Hey there !! am facing small problem with reshade i dont know if i am doing it right or not may i need help !!
Here is Prepar3D flight simulator i did some tweaking to make dof working but i still get all screen blurred !!
i use MasterEffect 1.1.115
Here is some screenshot to explain
store2.up-00.com/2015-04/1429534068291.png
I moved the eyepoint "Camera" to the nose of the plane it should autofocus but still blurred !!
store2.up-00.com/2015-04/1429534068762.png
The same thing here !!

And this is my current setting
www.dropbox.com/s/njlxsc5p4s535zy/MasterEffect.h?dl=0
Last Edit: 1 year 7 months ago by MaddogPilot.
The administrator has disabled public write access.

DOF Autofocus not working !! Prepar3D 1 year 7 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2458
  • Thank you received: 1394
Well, you have autofocus disabled, so that kind of makes sense =P

In your config file:
#define DOF_MANUALFOCUS 1
Set this to 0 to enable autofocus.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Marty McFly

DOF Autofocus not working !! Prepar3D 1 year 5 months ago #3

@Maddog (and of course Crosire)
When I try the Depth Test (Depth_Tech enabled with F12 - (had to stop Prepar3D.exe from using F12)), I get an all black image - I think this says that Prepar3D.exe doesn't provide a good Depth Buffer, so DOF effects will not work. Therefore, only Manual Focus will appear to give some kind of effect, but it is all blurred like your previous snapshot. I don't know why Prepar3D.exe won't provide a good usable DepthBuffer. Have you been able to get it to work somehow?
The administrator has disabled public write access.

DOF Autofocus not working !! Prepar3D 1 year 5 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2458
  • Thank you received: 1394
Any sort of DOF won't work without a working depth access, manual or autofocus. Make sure you disable any sort of AA in the game, because depth access only works with MSAA disabled. If the output is still black you're unlucky unfortunately, depth access is not supported for that game then (currently).
Cheers, crosire =)
The administrator has disabled public write access.

DOF Autofocus not working !! Prepar3D 1 year 5 months ago #5

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 610
  • Thank you received: 720
crosire wrote:
Any sort of DOF won't work without a working depth access, manual or autofocus

Well his statement is not entirely wrong. Autofocus detects focus plane depth 0 so everything that has depth = 0 is in focus, which is everything so no blur at all. While manual focus has something different than 0 as focus plane depth so it blurs the screen. Everywhere, but it actually blurs it. I guess that's what he meant.
The administrator has disabled public write access.

DOF Autofocus not working !! Prepar3D 1 year 5 months ago #6

I did make sure to turn off ALL Antitaliasing in FSX/Prepar3D.exe with the Control Panel, Nvidia Inspector, and the Prepar3D.exe application - made sure I saw jaggies. Stiil, nothing but black in the Depth Tech test. I guess the Depth Buffer is just not accessable for postprocessing.

Thanks much for the help!!!

Dave
Last Edit: 1 year 5 months ago by whitav8r.
The administrator has disabled public write access.