Welcome, Guest.
Username: Password: Remember me

TOPIC: Depth3d and Total War Warhammer 2 mouse cursor

Depth3d and Total War Warhammer 2 mouse cursor 2 months 2 weeks ago #1

This may seem like an obvious question which will likely have a disappointing answer but I was actually able to get a mild 3d effect in Total War Warhammer 2 even tho its not listed as supported by depth3d. I am using virtual desktop on an oculus CV1. Most other games work fine with this configuration using depth3d and reshade 3/4. The issue I'm having, and I've seen this with a lot of games, is that the cursor is offset by about 50 percent on the screen, to the left/right on SBS and to the top/bottom on OU because the game thinks the screen is bigger than the playable area. No, I have no scaling on in windows and I am running at bog standard 1920 by 1080. I've searched for hours on google and all I've learned is that I seem to be the only person on earth who tried to get this game working in 3D.

I am guessing this is something to do with a missing depth map or the shader is just not able to "hook" the cursor into the 3d positioning. I've tried using the virtual cursor but I could only get that to work by using the older superdepth shader and the game's cursor is still there and offset, and I can't stand having two cursors. The game's main cursor is still visible and still in the wrong position. Does anyone know how to to get the main cursor to sync with the cross cursor or make the main cursor invisible? Or better yet get the game's main cursor to be in the correct position? Or am I just out of luck as it is "not supported". I imagine we have some serious tinkerers on this forum who have worked miracles. Thanks in advance!
The administrator has disabled public write access.

Depth3d and Total War Warhammer 2 mouse cursor 2 months 2 weeks ago #2

First, you would need to enable the CrossCursor in Depth3D

Now from here the only thing I can think about is using a program called YoloMouse and Modifying/Adding a custom tiny little cursor.
You Can Get it here.
pandateemo.github.io/YoloMouse/
You have to make a Tiny Little Mouse Cursor So It's Not Distracting. You can even make multiple for different units. Like a Little X, a little Dot, or a little crosshair.
You can make it with www.rw-designer.com/online-cursor-editor


Once you make it, rename it to one of the built-in cur files for Yolo Mouse. ex: "1.cur"


This will NOT solve your problem 100%, But it will mitigate it.

I hope this helps. Depth3D is getting an update soon So you should get a bit more depth and better performance.
My GitHub page where you can get the Latest release of SuperDepth3D github.com/BlueSkyDefender/Depth3D

My PayPal Me Link If you like to donate paypal.me/BlueSkyDefender

Also my steam page steamcommunity.com/id/BlueSkyDefender

Discord Server discord.gg/W2f7YhX
Last Edit: 2 months 2 weeks ago by BlueSkyKnight.
The administrator has disabled public write access.

Depth3d and Total War Warhammer 2 mouse cursor 2 months 2 weeks ago #3

Wow thanks so much for responding! I have used the cross cursor and I actually do get it work, so that I can click where I am actually supposed to by using the superdepth shader, does not work with depth3d. At any rate, its more me being nit-picky that I can't stand seeing two cursors (the game one and the cross cursor). I love the idea of making a replacement cursor for it to make it fit the game better. Great suggestion. So, basically for anything RTS like Total War or Battletech you're basically out of luck eh? Anything with a cursor. I had the same thing with Grimrock. Great 3d effect but the cursor was in the way. I swear it has worked for some things, like Divine Divinity 2. Ah well, I really appreciate you responding tho! Thanks again.
The administrator has disabled public write access.