Welcome, Guest.
Username: Password: Remember me

TOPIC: Effects go crazy after loading screens

Effects go crazy after loading screens 3 weeks 21 hours ago #1

Hello everyone,

Im having an issue with certain shaders whenever the game loads. I’m playing KOTOR (OpenGL).

Basically it started when I downloaded a preset from the nexus forums. Once in game, I switched from default to the preset and boom it looked amazing. However, once I hit a loading screen, everything goes bonkers. Bloom goes crazy bright and everything turns black and white.

At first I thought it might be the preset so I just selected and adjusted to match the same effects in my defaultpreset. Still same problem. It also seems to only be an issue with certain effects like bloom.fx and emphasize... there are most likely others.

What the heck is going on?!? Lol it’s been driving me mad. Hoping it’s a noob error (this is my first go at reshade)

Any help would be much appreciated.
The administrator has disabled public write access.

Effects go crazy after loading screens 3 weeks 18 hours ago #2

This is normal. Those games do not clear the screen after each frame during loading screens, so the effects stack on top of each other (bloom applying to the bloom of the previous frame etc).
Cheers, crosire =)
The administrator has disabled public write access.

Effects go crazy after loading screens 3 weeks 10 hours ago #3

Damn... that does make sense. I wonder if there is a fix out there? Otherwise I have to switch back to defaultpreset before each loading screen. Kind of immersion breaking.

Anyways thank you for the help.
Last Edit: 3 weeks 10 hours ago by Alexander00.
The administrator has disabled public write access.