Newbie: Error in compiling' help needed.

More
11 months 3 weeks ago - 11 months 3 weeks ago #1 by bchick1
My first time using Re-Shader. I Installed the latest ReShade (v 4.6.1) in order to use an FO4 ENB ('Winter's Grasp'). On installing the ReShade 4.6.1 I opted to NOT install any of the defaults since I did not know what they were. So I answered 'None' to those options.
I downloaded the 'Reshade-Shaders' file for 'Winters Grasp' and followed the directions to point the ReShade application to the 'Reshade-shaders' directories ('shaders' and 'Textures'). This all seemed to go well.

However, I am receiving a notice and in the log that there was a 'errors' in compiling . The onscreen log shows some 'Warnings' in yellow and 'Errors' in red.

Errors were in : MagicBloom.fx ; FXAA.fx ; DOF.fx (five compile errors in DOF)

Does anyone know where I might look to rectify these warnings and errors?

Thank You!

I have the dxgi.log
Last edit: 11 months 3 weeks ago by bchick1.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #2 by crosire
Replied by crosire on topic Newbie: Error in compiling' help needed.
Hovering over the failures will tell you exactly what failed. Most likely a missing file. Just run the setup again and make sure to at least install the "Standard effects" package.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #3 by bchick1
Replied by bchick1 on topic Newbie: Error in compiling' help needed.
THanks. will do!

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #4 by bchick1
Replied by bchick1 on topic Newbie: Error in compiling' help needed.
I have captured the particulars of the error messages (RED font)
MagicBloom 3 errors: x3011 1 error x3538 all concerning ' value ...literal expression'

FXAA 2 errors: x3568 'interpolation qualifiers do not match vertex shaders ones'

DOF 5 errors: x3120 'invalid type for index. index must be an integer scaler'

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago - 11 months 3 weeks ago #5 by crosire
Replied by crosire on topic Newbie: Error in compiling' help needed.
You are using pretty old shaders (pre ReShade 4.0) that had mistakes that ReShade now correctly throws errors for. You'll have to update those. The legacy package in the setup will have all of those fixed.
Last edit: 11 months 3 weeks ago by crosire.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago - 11 months 3 weeks ago #6 by bchick1
Replied by bchick1 on topic Newbie: Error in compiling' help needed.
Thank you very much! Are you speaking ... "pretty old shaders" of the 'shaders' that came packaged with the mod. i.e. the 'reshade-shaders-master' files? I am assuming so ...
Thank you!
Last edit: 11 months 3 weeks ago by bchick1.

Please Log in or Create an account to join the conversation.