RTGI (RT Shader) Shadow/Lighting Issue

  • Posts: 8
4 weeks 17 hours ago - 4 weeks 17 hours ago #1 by sheno1346
Hey ya'll, got a bit of an issue. "Enable Precise Light Spreading" for the ray-tracing rtgi shader sometimes cuts off lighting, but disabling it removes some rtgi shadows.

Here are some comparison pics from phantasy stay online 2 showing what I mean.

In the first one, look how the 4 lamps on the right and the glowing purple table have unnecessary shadows added on them that are obscuring some of their light when Spreading is on, both on the actual objects themselves and the light bounce on the ground beneath them.

BUT, in the second 1, look how the robot straight up doesn't have any shadowing with rtgi when Spreading is disabled. Several items off screen such as couches and chairs lose their rgti shadows as well.

Any way to fix this? Maybe some kind of way to tweak how much Precise Light Spreading affects the image from 0 to 100, rather than just on and off?
Or a parameter so that precise light spreading doesn't activate on rtgi lights being cast close to an object? Since the lamps and table in the first pic are the ones emitting the light (so the light source is very close to the object), but the lighting on the robot, chairs, and couches is coming from the sun/large scale GI (so the light source is far from the object/off screen)



Please Log in or Create an account to join the conversation.

  • Posts: 179
4 weeks 8 hours ago #2 by klotim
why don't you ask in the patreon discord where you got the shader?

Please Log in or Create an account to join the conversation.