[SOLVED] DisplayDepth Showing Blocks Instead of Proper DOF

More
3 months 2 weeks ago - 3 months 1 week ago #1 by TheOnlyException
I am attempting to use DOF shader effects in The Sims 2 Ultimate Collection. My friend has gotten their display depth and DOF shaders to work properly with the game, so I know it's possible.

I have seen multiple people struggling with black or white screens when using DisplayDepth, but so far I have not been able to find MY issue, which is the presence of blocks. In the normal map they show up as rainbow blocks against a grey background, and in the other map they show up as block blocks against a white background (or if I tinker with the REVERSE, LOGARITHMIC, etc. settings, sometimes the blocks are white against a black background). I have tried messing around with the settings, changing REVERSE & LOGARITHMIC to 1 instead of 0. I have also tried accessing the DX9 tab to disable MSAA, but MSAA is not enable and the entire checkbox is greyed out so it is impossible to even enable in the first place.

Both my friend and I followed this tutorial to get ReShade working in-game:
meepingblog.com/gaming/sims2/reshade-4-0...he-sims-2-fix-guide/

One of my friends got DOF effects to work, and another one of my friends is having the white/black issue. I myself am having a completely different issue of blocks, as shown in the drive link. Please let me know if you can help!

https://drive.google.com/file/d/1Eanw_4yGx7OKytvKAKC4odgKrh-qtY6r/view?usp=sharing

My computer info:
NVIDIA GeForce GTX 1060 6GB
32GB RAM
AMD Ryzen 7 2700X Eight-Core Processor
ReShade 4.6.1
Last edit: 3 months 1 week ago by TheOnlyException. Reason: Problem solved

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #2 by TheOnlyException
Replied by TheOnlyException on topic DisplayDepth Showing Blocks Instead of Proper DOF
My friend was able to find the solution! For some reason, Smooth Edges makes it so the game can't identify depth. You'll need to turn Smooth Edges off in order for DOF effects to work properly.

If you have a NVIDIA card, you can enable "smooth edges" using the NVIDIA control panel so it's not a huge loss!

My friend made a tutorial on how to properly install ReShade for The Sims 2 as well, so if you find yourself struggling, check it out here!

Please Log in or Create an account to join the conversation.