PPFX_SSDO not working right with Geforce Experience - Ansel

  • Posts: 4
3 weeks 51 minutes ago #1 by suneelnairk34
Hi,

I am trying to use reshade shaders in the game Euro truck simulator 2 through the nvidia ansel route rather than the reshade application itself, as i want to take advantage of BenganJs antiliasing guide. I want to use the Kinematic-reborn reshade preset and I have managed to set up all the values similar to the kinematicreborn.ini file manually using the in-game geforce experience ansel filters, except PPFX_SSDO.

While using PPFX_SSDO (as described on the kinematic website) with reshade, we need to change 'global preprocessor definitions'. I am not able to find the this section while taking the geforce experience route and end up seeing the PPFX_SSDO shading upside down.

Can someone help me figure out how to set these values using the geforce experience interface? Any help would be much appreciated!

Regards,

Sunil

Please Log in or Create an account to join the conversation.

  • Posts: 3737
2 weeks 6 days ago #2 by crosire
For GFE you need to manually edit the shader files directly: Open ReShade.fxh and change "#define RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN 0" to "#define RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN 1".

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 weeks 6 days ago #3 by suneelnairk34
Thanks a ton and more! Will try that first thing tomorrow! Much appreciated!

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 weeks 6 days ago - 2 weeks 6 days ago #4 by suneelnairk34
Hi Crosire,

I did what you suggested. Basically made changes to the reshade.fxh file in the Ansel folder under Nvidia, but still see the effect inverted. It gets corrected when i alt-tab out of the game and back though...
However, while trying to enable ppfx_ssdo, i get a geforce experience error stating that depth buffer is not enabled for this game (game in question being ets 2). what i see are some shadows that are inverted? Does this mean it is not working right? If so, Is there any way to enable this?

Please Log in or Create an account to join the conversation.

  • Posts: 4
2 weeks 4 days ago #5 by suneelnairk34
Hi Crosire,

I believe i may have messed things up while saving my changes after reading another post in the forums. I used notepad to edit the values of the reshade.fxh to turn the depth input upside down to '1'. would it have caused the saved format to be different? Is there a preferred editor that I should download to open the .fx and .fxh files or will notepad suffice?

Please Log in or Create an account to join the conversation.