[SOLVED] SweetFX_settings.txt (1,1): error X3000

  • Posts: 7
4 years 7 months ago #1 by Proudi
SweetFX_settings.txt (1,1): error X3000: syntax error: unexpected 'unknown'

I get a problem with my Batman AK config....
If i download the config from " sfx.thelazy.net/games/preset/3990/ " rename it and overwrite the sweetfx.settings from the reshade install ..no problem
but if i change BORDER the error comes up??
If i dont overwrite the clean sweetfx.settings from reshade install and just copy&paste the settings(not the file) from the downloaded sweetfx.settings file i can edit the config with out any problem?

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

  • Posts: 3632
4 years 7 months ago #2 by crosire
Looks like you encoded the file in UTF8 with BOM. ReShade only understands ANSI.

Please Log in or Create an account to join the conversation.

  • Posts: 7
4 years 7 months ago - 4 years 7 months ago #3 by Proudi
hm but why it download the config as UTF8 from thelazy? my own config file is ANSI :O how can i change it that ppl download it as ANSI oO???

i copy the configs from the ANSI file and paste them into the preset Settings text:...and download it as UTF8 :O

Please Log in or Create an account to join the conversation.

  • Posts: 3632
4 years 7 months ago #4 by crosire
UTF8 alone is no problem, it looks the same as ANSI, as long as only ANSI characters (latin alphabet, numbers, and most symbols from a standard ISO keyboard) are used. But your file apparently includes a special header BOM (byte order mark) , which confuses ReShade (a lot of compilers don't understand it btw.). Double check you didn't accidently added that (Notepad++ has a few options to convert between different encodings for example) before uploading or after downloading.

Please Log in or Create an account to join the conversation.

  • Posts: 7
4 years 7 months ago #5 by Proudi
well i think the problem was ´ and ' ... my presets called Proudi's - blabla seems like i used ´ and not '...after i changed it the downloaded file is ANSI :O

Please Log in or Create an account to join the conversation.