Welcome, Guest.
Username: Password: Remember me

TOPIC: OmniFX v1.1 for Batman Arkham Origins need help !

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #1

Hello guys, I installed OmniFX v1.1 for AO (SSGI) but It does not work, when I press F12 for enabled, it's going nothing.
SweetFX work fine, but not SSGI.

You can help me please ?

Thank you.

Best regard.
Last Edit: 1 year 4 months ago by Killville. Reason: SOLVED
The administrator has disabled public write access.

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Make sure you don't have any ingame MSAA active and check if depth access works properly then (there is a depth output option, so check if you get some actual data and not just a blank image).
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Killville

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #3

Thank you for the fast response.
Ingame i do not have MSAA.
I have no blank image, SweetFX work but not SSGI.
I am sorry but, i did not understand your answer after ?
You talk about the depth ?
How to check the access of depth ?

Thanks.
Last Edit: 1 year 4 months ago by Killville. Reason: change
The administrator has disabled public write access.

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #4

  • JBeckman
  • JBeckman's Avatar
  • Offline
  • Posts: 162
  • Thank you received: 36
Killville wrote:
Thank you for the fast response.
Ingame i do not have MSAA.
I have no blank image, SweetFX work but not SSGI.
I am sorry but, i did not understand your answer after ?
You talk about the depth ?
How to check the access of depth ?

Thanks.

In common_settings.cfg set "USE_RFX_DisplayDepth" to 1 and then below that check what key "RFX_DepthToggleKey" is set to.

In-game press said key and a black & white sort of image will appear, this is the depth buffer for the game.
(Ensures that effects are drawn properly in-game instead of being overlaid on the screen which with for example DOF usually causes the image to become completely blurry.)

If it's full black or full white ReShade was not able to properly grab said depth buffer and effects such as ambient occlusion and depth of field will not work correctly.

Depth buffer detection works in Arkham Knight (Logarithmic depth buffer detection has to be off, that's another setting in the common_settings.cfg file but it's off by default I believe.) so I would assume it would also work in the older Origins game.

Origins do support MSAA which needs to be disabled for depth detection to work, forcing driver level AA also won't work.
(Such as SGSSAA for Nvidia and EQAA for AMD.)
The administrator has disabled public write access.
The following user(s) said Thank You: Killville

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #5

I followed your procedure and I get a black screen.
In Nvidia control panel is on AA disabled, also ingame.
I do not understand, yet it is Omnipotus who did realised this pack AO (SSGI) for Batman Arkham Origins, please see here: sfx.thelazy.net/games/preset/3982/
Thank you for your help.
The administrator has disabled public write access.

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #6

  • Kleio420
  • Kleio420's Avatar
  • Offline
  • Posts: 216
  • Thank you received: 28
Killville wrote:
I followed your procedure and I get a black screen.
In Nvidia control panel is on AA disabled, also ingame.
I do not understand, yet it is Omnipotus who did realised this pack AO (SSGI) for Batman Arkham Origins, please see here: sfx.thelazy.net/games/preset/3982/
Thank you for your help.
can you screenshot your settings please lol, also you are getting reshade working to start with right try deleting it from the folder and putting it back after launching the game once to make sure its not how its placed.Any errors show as you start up the game ?Also for the heck of it try disabling dof along with msaa(txaa as well uses msaa buffer) see if that helps any
The administrator has disabled public write access.
The following user(s) said Thank You: Killville

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #7

My settings ingame


My log with OmniFX v1.1 Batman Arkham Origins by Omnipotus


Log in pack OmniFX v1.1 Batman Arkham Origins by Omnipotus

""Any errors show as you start up the game ?"" = Not any errors.
The administrator has disabled public write access.

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #8

  • Kleio420
  • Kleio420's Avatar
  • Offline
  • Posts: 216
  • Thank you received: 28
Killville wrote:
My settings ingame


My log with OmniFX v1.1 Batman Arkham Origins by Omnipotus


Log in pack OmniFX v1.1 Batman Arkham Origins by Omnipotus

""Any errors show as you start up the game ?"" = Not any errors.
did you try turning depth of field off to see if that was maybe causing it ?
The administrator has disabled public write access.
The following user(s) said Thank You: Killville

OmniFX v1.1 for Batman Arkham Origins need help ! 1 year 4 months ago #9

I am so happy :woohoo: i found the solution.
1/I copy all the settings for AO which are in the file McFX_settings.cfg, in SweetFX_settings.cfg file.
2/I change the resolution of the screen in 2240X1400 (before 1840X1150) and now it works !

Some screenshot.
In 1840X1150 it does not work.


Settings 1840X1150.


Now in 2240X1400.


Settings in 2240X1400.


Thank you to all those who have tried to help me ;)
The administrator has disabled public write access.