The DEPTH-CHECK feature of Bloom.fx's Godrays is not functioning properly.

  • ymt
  • Topic Author
When I set DEPTH-CHECK to 0 (disabled), the effect applies to all light sources, which I don't want. I want the effect to be applied only to light sources coming from the sky, specifically those from the sun. However, when I set DEPTH-CHECK to 1 (enabled), all the effects disappear.

In Half-Life 2, the Godrays effect is correctly applied only to distant light sources. However, in games like RE8 or DeathLoop, it becomes completely disabled.

While setting DEPTH-CHECK to 0 (disabled) works, it applies the effect to all light sources, which is not what I want.

How can I make it so that the Godrays effect only appears for distant light sources, like the sun or the sky? If achieving this with bloom.fx is not possible, please recommend another Godrays effect that could work.

Please keep in mind that I cannot understand English, and I used ChatGPT to translate this message. So, I would appreciate it if you could reply in English that is as easy for translation software to understand as possible.

Please Log in or Create an account to join the conversation.

We use cookies
We use cookies on our website. Some of them are essential for the operation of the forum. You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.