[SOLVED] GemFX breaking Reshade in Mafia 2

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
4 years 7 months ago - 4 years 7 months ago #1 by Quentin-Tarantino
When i active any of the GemFX FX in Mafia 2 Reshade fails with a bloom error!

Makes no difference which GemFX FX i turn on 1 by 1 i get same bloom error!
- Ambient Light by itself bloom error!
- Bloom by itself bloom error!
- Lens Dirt by itself bloom error!
- Gaussian Anamorphic by itself bloom error!
E.T.C by itself bloom error!

Not to sure what the problem is because the rest of Framework works perfectly with Mafia 2 when GemFX is disabled..

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 7 months ago #2 by crosire
Could you be more specific on that "bloom error"? Does shader compilation fail? If so, what's the exact error message? =)

Please Log in or Create an account to join the conversation.

  • Posts: 790
4 years 7 months ago #3 by Ganossa
Sounds to me as if there is a conflict between shader and duplicate defines, at least that was a problem of the past with bloom?

Please Log in or Create an account to join the conversation.

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
4 years 7 months ago - 4 years 7 months ago #4 by Quentin-Tarantino
crosire

Yea reshade fails.

LuciferHawk

I am getting the same problem with Blues & Bullets now :)

GemFX Seems to fail when i have sin city fx activated or when sin city fx is already build in game like Blues & Bullets

Please Log in or Create an account to join the conversation.

  • Posts: 790
4 years 7 months ago #5 by Ganossa
Please try with a clean installation of the new release :)
The following user(s) said Thank You: Quentin-Tarantino

Please Log in or Create an account to join the conversation.

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
4 years 7 months ago - 4 years 7 months ago #6 by Quentin-Tarantino
The bloom shader was missing from the Reshade + Framework that i backed up lol

It's working perfectly now :)

Please Log in or Create an account to join the conversation.