Welcome, Guest.
Username: Password: Remember me

TOPIC: Prevent ReShade from rendering to part of screen

Prevent ReShade from rendering to part of screen 1 year 1 month ago #1

I've been playing 4:3 games with DOSBox Daum SVN (D3D output) and ReShade. Awesome that it works.

As you'd imagine, these games are all 4:3 rather than 16:9. Unfortunately, when using ReShade, the unused sides turn into a sort of "hall of mirrors" effect, like when a texture was missing in Doom. The welcome message, as I noted in another thread, never disappears because of this.

More importantly, some ReShade effects like Gaussian Anamflare can "bleed" into the black bars and set off hall of mirror explosions. Here's a several-second time-lapse after I enabled Gaussian Anamflare in Dark Forces. My preset looks really nice until that kicks in.

As a quick fix, is there a way we could prevent ReShade from addressing parts of the screen? Either precisely, or by telling it what aspect ratio to render to (4:3 in this case).

A precise option would also be helpful to screen out HUDs, which I imagine has been suggested before.

Thanks for this rad tool.
The administrator has disabled public write access.

Prevent ReShade from rendering to part of screen 1 year 1 month ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1384
There is an "UIMask" effect in the ReShade framework, which lets you mask out specific parts of the screen and should do exactly what you want. Enable that shader and edit the "ReShade\BasicFX\Textures\uiMask.png" image so the left and right side are black and everything else is white.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Alexandra

Prevent ReShade from rendering to part of screen 1 year 1 month ago #3

Ah, silly of me. Thanks much.

A few thoughts:
1) Switching from fullscreen (16:9 screen mode with aspect-correct 4:3 picture and black bars on sides) to windowed mode (just 4:3) means the 4:3 mask is no longer appropriate. It'd be interesting if one could make certain effects only apply to fullscreen or windowed mode, for cases like this.

2) In a half hour of trying different tricks I could not get the UIMask toggle hotkey to work.

3) Interestingly the welcome message continued to persist / hall-of-mirror itself on the left side even with UIMask active. No biggie. I don't suppose there's a shader that just throws up an image onto the screen, like the border shaders in RetroArch? That might make the glitchy text disappear.

4) Here is a very precise 1080p 4:3 mask.png if anyone would like it.
Last Edit: 1 year 1 month ago by Alexandra.
The administrator has disabled public write access.

Prevent ReShade from rendering to part of screen 1 year 1 month ago #4

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
The text is rendered on top of all shader so it cannot effect the shader output and the other way around.

Did you get the UIMask working?
If not, you can read up about its handling here
reshade.me/forum/general-discussion/393-tutorial-for-users

Most of it is unfortunately not up to date anymore but check out point 3.1 for the UI Mask tutorial :)
The administrator has disabled public write access.