Welcome, Guest.
Username: Password: Remember me

TOPIC: Add some way to force a mouse cursor?

Add some way to force a mouse cursor? 1 year 2 months ago #1

So far there have been three games (saints row 2, medal of honor pacific assault, and i forget the third but it was a while ago) that i cannot use reshade in because there is no mouse cursor to change reshades options.

However in these games when you press shift+F2 the mouse cursor gets glued to the center of the screen and you can not do anything with reshade. I have tried running these games in windowed mode but the issue persists. MOH:PA has a mouse cursor in-game but it does not move reshades mouse cursor. I know some games you need to press esc and open a menu to get the mouse cursor to work but not with these games unfortunately.

I dont even know how to begin suggest fixing this. Is there any way you can give reshade some sort of standalone mouse cursor? Or maybe some forced mouse cursor mode?
The administrator has disabled public write access.

Add some way to force a mouse cursor? 1 year 2 months ago #2

Also happening with Need for Speed 2 SE. :blush: Trying to install reshade version 2.x since version 3.0 is having a lot of issues with OpenGL and, Glide and OpenGL are similar if I've heard right.
The administrator has disabled public write access.

Add some way to force a mouse cursor? 1 year 2 months ago #3

Happens in Witcher 3 as well when Nvidia Ansel Overlay is open. That one is particularly bad.
The administrator has disabled public write access.

Add some way to force a mouse cursor? 1 year 2 months ago #4

This has nothing to do with graphics APIs. What's happening is that many games lock the mouse cursor to the center of the screen to calculate the delta mouse movement from it. ReShade already has some workaround code to disable this for some ways it can be achieved (which works in a lot of games, else you wouldn't be able to move the mouse in pretty much every game). Apparently there are more ways to do this that ReShade doesn't handle yet though.
Cheers, crosire =)
The administrator has disabled public write access.