On/Off option for Log.

More
5 months 3 weeks ago #1 by markhad
On/Off option for Log. was created by markhad
When I use ReShade on PCSXR-PGXP emulator it constantly write the following warn:

16:07:59:702 [03360] | WARN | Skipping render context 00010001 because there is no window associated with its device context 1A011325.
16:07:59:719 [03360] | WARN | Skipping render context 00010001 because there is no window associated with its device context 1A011325.
16:07:59:736 [03360] | WARN | Skipping render context 00010001 because there is no window associated with its device context 1A011325.
16:07:59:752 [03360] | WARN | Skipping render context 00010001 because there is no window associated with its device context 1A011325.
16:07:59:769 [03360] | WARN | Skipping render context 00010001 because there is no window associated with its device context 1A011325.

...

These warnings doesn't affect the game reshading process at all, but increases RAM consumption to a high level. I've already set the log file to read-only mode, but that only saves disk space; while the process is running RAM is affected a lot.

Is there a way to deactivate the log writing process in the reshade config file?

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago #2 by crosire
Replied by crosire on topic On/Off option for Log.
There is not. But github.com/crosire/reshade/commit/0c3452...b449775e8c4bb0bdfc07 changes things so that the log is not kept in RAM as well now (unless you click on the Log tab in the UI, and then it's truncated to 1000 lines).
The following user(s) said Thank You: markhad

Please Log in or Create an account to join the conversation.