Vsync through reshade, hear me out please...

More
9 months 2 weeks ago #1 by Yourselfhere
Vsync through reshade, hear me out please... was created by Yourselfhere
i realize it has been proposed before and no real need for it was found but i have something, "optimus". almost all laptops using nvidia gpu use the optimus technology and as such, they don't adaptive vsync, fastsync, half rate vsync or any other vsync. now one might say that vanilla vsync does the job well enough, which might be great if it worked. i am not sure if its nvidia drivers or windows update but it hasn't worked in a long time. i wanted to use it for witcher 1 which doesn't have vsync and hit only two of my four core cpu, and it hits them hard to the point it becomes the bottleneck first in unlocked frame rate which is probably the reason this game is well known for stuttering, i tried to lock the frame rate to 60 which seemed to help with the stutters but introduced horrible tearing, much worse than with unlocked frame rate. there are quite a few old games that don't have vsync and there doesn't seem to be any reliable way of getting across this optimus hurdle, i've seen some suggest "disable full screen optimisations" in windows 10 but that doesn't always work and in my case i couldn't even start the game after that. i don't know if its even possible to do it through reshade but i don't know any other software that might be able to do it. there are a lot of people who could really use it, a half rate vsync will be a godsend to laptop users with weaker gpus.

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago - 8 months 2 weeks ago #2 by lowenz
Last edit: 8 months 2 weeks ago by lowenz.

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #3 by aaronth07
Replied by aaronth07 on topic Vsync through reshade, hear me out please...
Have you tried Special K?

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #4 by Daemonjax
Replied by Daemonjax on topic Vsync through reshade, hear me out please...
Witcher 1 is dx9, so have you tried using d3doverrider (was part of the OLD rtss: community.pcgamingwiki.com/files/file/84-d3doverrider/) for triple buffering and then use the newest rtss for setting a framerate just slightly below (like 0.01 frame) your true (www.testufo.com/refreshrate) vertical refresh?

This works on windows 7.  I dunno about windows 10.  I'm 99% sure windows 10 triple buffers everything in borderless windowed mode (not fullscreen).  It might be a dx11 thing.  No idea, since I I'm still on Windows 7 for my gaming pc.

That's pretty much how I run every dx9 game -- d3doverrider for triple buffering vsync, then use the frame limit trick to reduce input lag to an acceptable level and getting rid of some weird microstutter. That should provide the smoothest framerate you're going to get in a dx9 title.  It's an old trick that works better now since we have such an accurate framelimiter in the newest rtss (but the newest one lacks triple buffering because windows 10).  Must have something to do with keeping the buffer queues starved.

Edit:  I see you're on Windows 10... So... try running it in borderless mode (if it doesn't have a borderless windowed mode, just make it happen anyways using 3rd party tools) and try to get rtss to limit framerate to 0.01 frames less than your actual vertical refresh -- maybe would have to use a global profile instead of an application specific one for it to work..
Last edit: 2 months 3 weeks ago by Daemonjax.

Please Log in or Create an account to join the conversation.