[SOLVED] GTA V + ReShade + ENB = not working

More
5 years 11 months ago - 5 years 11 months ago #1 by MonarchX
GTA V + ReShade + ENB = not working was created by MonarchX
I know it is very possible to run GTA V with the latest ENB and ReShade at the same time because I saw quite a few people and profiles for that combination, but I cannot get it to work on my own!!!

I use ReShade's x64 DXGI as ProxyLibrary and edit ENBLOCAL.INI like this:
[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=dxgi.dll

Yet I cannot start the game because it CRASHES! I only enable several ReShade effects - FXAA, LumaSharpen, and TuningPalette (3DLUT). For ENB I only enable its superior MSAA...

How do others make it work???
Last edit: 5 years 11 months ago by MonarchX.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #2 by Vivid Clarity
Replied by Vivid Clarity on topic GTA V + ReShade + ENB = not working
I am having this very problem, but I'm not sure if it has to do with me running Windows 10 or not.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3 by crosire
Replied by crosire on topic GTA V + ReShade + ENB = not working

ProxyLibrary=dxgi.dll

That cannot work. ReShade will be loaded twice this way, once by the game and a second time by ENB. Use some other name, like "ReShade.dll".

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago - 5 years 11 months ago #4 by MonarchX
Replied by MonarchX on topic GTA V + ReShade + ENB = not working
If I rename dxgi.dll to ReShade.dll and edit ENBLOCAL.INI like this:
EnableProxyLibrary=true
InitProxyFunctions=true
ProxyLibrary=ReShade.dll
then I get a crash on startup, before GTA V intro video begins playing.

If I rename dxgi.dll to ReShade.dll, but leave ENBLOCAL.INI like this:
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=
then only ENB loads, without ReShade

If I leave dxgi.dll as dxgi.dll, but leave ENBLOCAL.INI like this:
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=
Then only ReShade loads, without ENB

d3d11.dll is already taken by ENB, so I cannot use it for ReShade.

There's got to be a way to make ENB and ReShade work together though - I know it is possible...
Last edit: 5 years 11 months ago by MonarchX.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #5 by MonarchX
Replied by MonarchX on topic GTA V + ReShade + ENB = not working
I got it to work!!!!! Here's how:
EnableProxyLibrary=true
InitProxyFunctions=FALSE
ProxyLibrary=ReShade.dll

All I had to do was set InitProxyFunctions to FALSE! I always left it at true because that was the default!
The following user(s) said Thank You: jas01

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #6 by ibbanez
Replied by ibbanez on topic GTA V + ReShade + ENB = not working
Has anybody else gotten this to work in Windows 10 64 bit Pro? I can get the ENB to run, I can get ReShade to run, but both I get CTD immediately. I've tried every possible enblocal.ini config possible. Im at a loss as to what to try.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #7 by ibbanez
Replied by ibbanez on topic GTA V + ReShade + ENB = not working
I also forgot to add that I have no problem running Fallout 4 with both ENB and ReShade, including the new ENBSeries .284 that he just released. This has been frustrating to say the least. Any thoughts or help would be greatly appreciated. Thanks.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #8 by ibbanez
Replied by ibbanez on topic GTA V + ReShade + ENB = not working
Just a quick update. I was able to get this to work with using ReShade + SweetFX 2.0 v. 0.17.1, however version 0.18.x and newer, CTD immediately. I'm not sure what changed from version 17.1 to 18, but it will not work at all.. Any thoughts?

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #9 by Ex1P
Replied by Ex1P on topic GTA V + ReShade + ENB = not working
Anyone know how to fix enb can't install for fivem? i already installed but nothing happened and the enb dont appear at the top left after i open fivem
Thanks if u can help me

Please Log in or Create an account to join the conversation.

More
4 days 4 hours ago - 4 days 4 hours ago #10 by dempsterz
Replied by dempsterz on topic GTA V + ReShade + ENB = not working
Here how to fix!
Follow his step
Change name dxgi.dll to ReShade.dll and Edit ENBLOCAL.INI
EnableProxyLibrary=true
InitProxyFunctions=false
ProxyLibrary=ReShade.dll
and keep that file [not delete]

next step Copy ReShade.dll and Paste ReShade.dll into the folder FiveM\FiveM Application Data\bin

Now your FiveM + ReShade + ENB is working!
Sorry for my English
Last edit: 4 days 4 hours ago by dempsterz.

Please Log in or Create an account to join the conversation.