Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Final Fantasy Type-0 HD

Final Fantasy Type-0 HD 1 year 3 months ago #1

Has anyone tried reshade with this Final Fantasy Type-0 HD? I see a preset at sfx.thelazy.net/games/preset/4231/ which appears to be using an older reshade? The person who posted it just says to download reshade and sweetfx 2.0 and put it in the folder with the exe (and there are 2 folders with exes, neither working with mediator for me)

It's a steam game, it has a launcher in the game folder, and in a subfolder is the actual game executable. In the folder with the game executable is a dll which i think is making reshade not work: d3dcompiler_46.dll. Reshade doesnt even write anything in the logs (the log is in the mediator folder), I even tried 32 and 64 bit dlls just to make sure.
Last Edit: 1 year 3 months ago by sajittarius.
The administrator has disabled public write access.

Final Fantasy Type-0 HD 1 year 3 months ago #2

  • JBeckman
  • JBeckman's Avatar
  • Offline
  • Posts: 163
  • Thank you received: 36
I'm no expert but d3dcompiler_46.dll shouldn't be a issue, it's one of the D3D11 components of DirectX (11_0, I think _47 is 11_1) and I don't think it's included by default in Windows 8.1 or Windows 10 (And the DirectX runtime redistributable itself hasn't been updated since 2010 but is still required for getting the additional files for D3D9 and 10 that are still not part of a default Windows install for whatever reason.) so games and programs using that version of the Windows SDK (Or what it's called now.) would have to supply the file together with the application (I think Steam is one such program, has both the 32 and 64-bit version of the .dll even.) anyway using ReShade64.dll named to DXGI.dll should hook via the D3D11 API, works here at least (Game uses DirectX 11.0 and it's 64-bit.) although if you want to use depth dependent effects such as some alternate DOF shader or maybe add some extra AO you have to keep AA disabled in the games launcher.

While on the subject of AA for this game low is a temporal AA method (SMAA T1X ?, I do not know.) and that might work however high is a 1.5x1.5 SSAA method and very high uses 2x2 both of which break depth buffer access. (Both are also pretty costly in terms of performance and the temporal AA is used alongside SSAA so you do get some blur, very noticeable on character models, their faces especially.)


EDIT: Oh right, I don't use the mediator.
(I copy things manually just because to me it's more convenient, install wise that's either ReShade32 or ReShade64 .dll and then name it to whatever API the game is using - d3d9.dll, dxgi.dll or opengl32.dll - along with the ReShade.fx file and of course the ReShade folder and it's subfolders for the actual shader and config files.)

EDIT: While I have not used Mediator myself and as such don't exactly know how it works maybe double check just in case and see what the path to the game exe is in that program or how might works. (profile system?)

That might be why it does not work if it's targeting the launcher and not the actual game exe. :)

C:\Program Files (x86)\Steam\SteamApps\Common\FINAL FANTASY TYPE-0 HD\fftype0hdlauncher.exe <- This is just a launcher, sets up the graphics and other options that you want to use.

C:\Program Files (x86)\Steam\SteamApps\Common\FINAL FANTASY TYPE-0 HD\WIN\fftype0hd.exe <- This is the real game exe and where I have the ReShade related files.
Last Edit: 1 year 3 months ago by JBeckman.
The administrator has disabled public write access.

Final Fantasy Type-0 HD 1 year 3 months ago #3

Interesting, yea i targeted both launcher and exe, neither worked (but the mediator was defaulting the dll to d3d9.dll)... I'll try manually renaming it to dxgi.dll. I knew about the high AA settings being SSAA, but i didnt know that broke depth buffer access, good to know!

I'll try it when i have time today; I bet dxgi does the trick.

Edit: It worked! Now I can spruce up these PSP graphics a little, lol. Thanks :)
Last Edit: 1 year 3 months ago by sajittarius.
The administrator has disabled public write access.