[SOLVED] Guild Wars 2 and ReShade Issue (Razer Synapse)

  • Posts: 2
4 years 6 months ago - 4 years 6 months ago #1 by Joekamo
I have been trying to use reshade with Guild Wars 2 but my game keeps crashing. I believe it's a reshade issue because my game runs if the reshade files are not installed. It's not a very old install of the game since I recently reinstalled it on a different hard drive. It's in the Program Files (x86) folder, the files are in the bin folder and I am using reshade32.dll as d3d9.dll. I have reinstalled several versions of visual c++ redistributable and verified that my directx is current on
Windows 10.

When opening the game (as administrator) it will say Initializing, then gives me a crash report. I use a razer naga and turned off synapse but that did not help.
Here is the d3d9 log:
Warning: Spoiler! [ Click to expand ]

And if it'll help, the GW2 crash report:
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 6 months ago #2 by crosire
Sounds like a typical hooking conflict. Some other software must be running, which tries to hook into the game too. Overlays, screen capture, streaming, game boosters, etc. for instance.

Please Log in or Create an account to join the conversation.

  • Posts: 2
4 years 6 months ago #3 by Joekamo
So it was Razer Synapse that was causing the issue. Not sure what happened the first time I turned synapse off but after your reply I did it again and my game loaded up. Thank you for that.

I looked into it further and found a post on razer forums talking about crashing issues with multiple games using sweetfx. It was found that ending the "RazerIngameEngine.exe" process in task manager will allow you to run a sweetfx game alongside synapse. Tried it and it does work.

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 6 months ago #4 by crosire
Cheers =)

Please Log in or Create an account to join the conversation.