Welcome, Guest.
Username: Password: Remember me

TOPIC: Problem with Offline Preview

Problem with Offline Preview 1 year 8 months ago #1

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 158
  • Thank you received: 128
I have the problem that the preview feature doesn't work as intended. It seems that effects get applied multiple times while switching back to the correct image constantly (resulting in a flickering view). This also happens with the lut preview.
Therefore it's really difficult to get the right moment to extract the correct lut (which is my intention)
As far as I remember, I have this issue since the very first builds.
I've tried it with vsync and fps cap, by disabling all sort of hooking overlays, but to no avail. GPU is an AMD.

Log: pastebin.com/Cs0xqsGL (For this I've disabled all effects. but the problem is also visible on ReShade's starting message.)
Last Edit: 1 year 8 months ago by brussell.
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #2

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
Sounds like its reloading constantly. It usually reloads when you change the size of the window. Would you try to maximize the preview window and see if the issue remains?
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #3

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 158
  • Thank you received: 128
I've tried that already, but it doesn't help. Maximizing the image just slows down the flickering. Also the welcome message goes away normally after a few seconds, but the flickering persists.

Here is an example. The screen constantly flickers between these images:
Normal Image
Expected Image
Overprocessed Image (and sometimes it's worse, like an image processed 3,4,5 times )
Last Edit: 1 year 8 months ago by brussell.
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #4

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
Hm, so you think it is not reloading the shader?
Does the same thing happen if you use it in a game or for e.g. VLC player?

I also added some additional buffering for the preview (helps re-sizing) that could cause flickering but it should usually help with loading the image not have a negative effect...

Can you give me your email address?
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #5

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 158
  • Thank you received: 128
I have no problems with games whatsoever. I haven't tried it with vlc though.
Btw, there are two other observations I've made:
1. Hovering the mouse cursor over the preview screen accelerates the flickering
2. Often the screen gets drawn in weird way in rectangles of different sizes. Sometimes only these rectangles are showing the applied effects.

Do you have a public email address you can post here. Or can I write to info (at) reshade.me about this.
I'm hesitating to post it here (where is the pm feature, when you need it :whistle:)
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #6

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2650
  • Thank you received: 1520
brussell wrote:
Or can I write to info (at) reshade.me about this.
You can, I'll forward it to Lucifer.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: brussell, Ganossa

Problem with Offline Preview 1 year 8 months ago #7

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 158
  • Thank you received: 128
So, have you received the mail LuciferHawk?

In the meantime I've tried the the offline preview with another, completely different setup (only similarity is Windows 7 64). And it shows the same behavior, just with less frequent flickering (probably caused by slower hardware). So it seems that this issue can't be that uncommon?

Nevertheless, when I cap the framerate (which results in an still image) and resize the window (updates the image) I'm able to extract the right lut most of the time.
I'm fine with that. But I'm not aigainst a real solution for this problem of course.

Thanks for the help (and especially for the ability to extract the lut, very nice feature!)!
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #8

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
Yes, Crosire gave me your email address. Just in case I want to send you a test build :)

I have not heard of that issue yet. What was your other setup, can you also try it on a different system?
What GPU do you have on your current system and is there any other overlay program or similar running?
The administrator has disabled public write access.

Problem with Offline Preview 1 year 8 months ago #9

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 158
  • Thank you received: 128
No Overlays. (not even background processes). Latest drivers were installed
Main system: AMD chipset, GPU: AMD HD7850
Other system: Laptop: Intel chipset, GPU: NV Geforce 310M
(I can give you further details via email, when you give me your address)

I've made some other screenshots for better understanding:
Normal Image
One can clearly see the overlapping frames
Here one can see the weird buildup of the image
The administrator has disabled public write access.

Problem with Offline Preview 1 year 7 months ago #10

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
I more strictly separated LUT rendering from picture rendering now (LUT will only show when L-key is pressed) which might already help with your issue.
The administrator has disabled public write access.