Welcome, Guest.
Username: Password: Remember me

TOPIC: Keybinds not working in game (FFXIV)

Keybinds not working in game (FFXIV) 1 year 2 months ago #1

I've been trying to get ReShade to work in FFXIV and I think my noob is really showing. I've set keybinds to F11 and F12 for toggling effects in Global_Settings (I think I did anyway), killed their keybinds within the game, and downloaded a pre-set into what I think must be the right folder. Rebooted game.

Game launches no problem, I get the Reshade message at start that says compile was successful..... and then nothing is different about the game at all. It looks exactly the same as it did before, and hitting the keys I thought were supposed to toggle didn't help.

Never messed with Reshade or SweetFx or anything remotely like this since the old days of Windower on FFXI, so I'm probably skipping some stupidly obvious but vitally important step. Does anyone know what I have to do to get my effects to work?
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 2 months ago #2

  • bopper2010
  • bopper2010's Avatar
  • Offline
  • Posts: 32
  • Thank you received: 9
Sounds like your using an older version of Reshade possibly with SweetFX, I only know the way to do it in the newer Reshade Framework/Mediator tool.
If you have the Reshade Framework and Mediator downloaded, there is a Reshade folder inside the main downloaded file, inside that folder are all the shader files for SweetFX, McFX, etc. Look for the Commom.cfg file, open it and you will see this line in the cfg file,

[#define RFX_ToggleKey VK_SCROLL //[undef] //-Set the global key that should toggle the effects On/Off.]

That is the Default Scroll Lock key to toggle effects, you need to then open the Keycodes.h files which is located inside the Personal Files folder inside the main Reshade archive you downloaded. This Keycodes file will tell you the correct ANSI keys codes to use instead of Scroll Lock and then you just replace the above VK_SCROLL with the corresponding entry for F11 or F12 in ANSI format.

Those entries are listed as this in the Keycodes.h file, so simply replace the VK_SCROLL with the either the F11 or F12 keycode values below.

#define VK_F11
#define VK_F12

Sorry I cant help you with doing it for older versions or SweetFX standalone but that cause Im used to Mediator and Framework and you never specified what versions you were personally running.
The administrator has disabled public write access.
The following user(s) said Thank You: tprara

Keybinds not working in game (FFXIV) 1 year 2 months ago #3

Ah, that already did help a lot - I've installed and was trying to run 1.0 but all the other XIV guides out there for SweetFx make reference to the previous versions. With "copy these files and stick them in this folder!" But if the new framework doesn't use those files, then it makes sense they'd have no effects.

So, I've opened the Common_settings.cfg and added in the codes for F11 and F12, booted up the game and..... still nothing. Looks no different. Clicking F12 doesn't toggle anything on. (I also discovered that Windows 10 had blocked most of the cfg files so I went through and un blocked them all.) I even tried changing them to the 104 keyboard number to see if that made a difference since I'm using a cheap standard 104 for now.

So it appears the effects are loading fine when I've got them set to initial boot, but the keybinds are still unresponsive when I try to toggle them inside the game.
Last Edit: 1 year 2 months ago by tprara.
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 2 months ago #4

  • ninjafada
  • ninjafada's Avatar
  • Offline
  • Posts: 38
  • Thank you received: 5
could you try my settings ? ninjafada.com/sweetfx/FFXIVARR/rshd-dx11-02.zip extract in X:\SquareEnix\FINAL FANTASY XIV - A Realm Reborn\game
it's for dx11 64bits
the bind to toggle off on is on menu select (key on the left on the right ctrl )
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 2 months ago #5

I tried using your files but they just make my game crash on launch.
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 2 months ago #6

  • ninjafada
  • ninjafada's Avatar
  • Offline
  • Posts: 38
  • Thank you received: 5
hm that's weird lot of people in my guilde are using it, win 7 and 10 dx11 64bits without any problem

can you post the dxgi.log and a list of process running ?
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 2 months ago #7

The game doesn't even get to a point where it puts anything into the logs with your settings. As a test, I removed them and put a clean install of Reshader back in and it booted fine. (And I am pretty sure Reshader itself is running, since I picked a much wackier preset last time to be sure.) Replaced yours again, and it crashes again.

Here is the dxgi.log file from the last time I successfully booted:

Warning: Spoiler! [ Click to expand ]


Processes running:
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

Keybinds not working in game (FFXIV) 1 year 1 month ago #8

Just a note that this is still an issue.

I've confirmed that Reshade is working fine - looking at FFXIV in sweet sweet '70s Technicolor right now :P The only thing NOT working are toggles for turning effects off in game. None of them work, no matter what keys I map them to.
The administrator has disabled public write access.