[SOLVED] Warcraft 3 issues

More
7 years 9 months ago #1 by MS-DOS Warcraft 3 issues was created by MS-DOS
With 0.11.0.620 the game just doesn't launch. It says that it couldn't initialize DX 8.1 because it's probably not installed on my system.
Tracelog

It did, however, launch with a previous ReShade version, but the right part of the screen was corrupted and it crashed when i was trying to start a game.

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago #2 by MS-DOS Replied by MS-DOS on topic Warcraft 3 issues
0.11.1 behaves the same way as 0.10.0 did, but doesn't crash when starting a game.
I get this screen corruption in every game i try, even DX9, when ReShade.fx is in the folder.
Tracelog

BTW, i've managed to get GeDoSaTo working with WC3 using ReShade :) Shaders and AA apply, but downsampling is kinda broken - the image is blurred even using nearest scaling, which shouldn't happen. Does ReShade itself use any kind of scaling ?

Please Log in or Create an account to join the conversation.

More
7 years 9 months ago - 7 years 9 months ago #3 by crosire Replied by crosire on topic Warcraft 3 issues
This is no corruption, this is exactly what is supposed to happen with the default ReShade shader. That version is for shader developers =):
It demonstrates a simple texture-blur and the right side of the screen shows the depthbuffer contents.

I encourage you to download the ReShade + SweetFX package instead, which has a bunch of nice shaders to play round with included.
Last edit: 7 years 9 months ago by crosire.
The following user(s) said Thank You: MS-DOS

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.