Depth flickering in Live for Speed

More
4 years 11 months ago #1 by Darecki
Depth flickering in Live for Speed was created by Darecki
Hey!
At first I'd like to say that I'm amazed with this great tool :)
However, I'm facing an annoying problem when I try to use Reshade with Live for Speed game. After enabling depth access it is "turning" itself on and off, in windowed mode it stays on for a longer period of time, but in fullscreen it's off most of the time.
It uses dx9, I turned AA off, tried varios depth settings, loading it with enb injector, enbseries, even tried different drivers (GTX660).. And no luck.
I tried Reshade in Max Payne 2 already and everything works like a charm there.
Enbseries' depth is working fine in LFS too..

Have anyone ever had such problem?

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #2 by crosire
Replied by crosire on topic Depth flickering in Live for Speed
Online or offline?

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #3 by Darecki
Replied by Darecki on topic Depth flickering in Live for Speed
Offline, didn't even check it working online.
Oh, and here's log file:
pastebin.com/Sqf6z9JM

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #4 by crosire
Replied by crosire on topic Depth flickering in Live for Speed
Either way, that's just how ReShade's generic depth buffer detection works. It sometimes fails to find the right buffer, which then makes itself notice in the flickering you describe.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago - 1 year 5 months ago #5 by tsilliev
Replied by tsilliev on topic Depth flickering in Live for Speed
Necroing this because I am experiencing the same issue in WoW, if I am not moving, the depth (distance between the 2 squares) is not changing, when I start rotating the camera, then it starts flickering, the depth blackens then returns to normal, then blackens again etc.
No solution? Tried turning it off, but autorange depth is not turning it off, it just changes the min/max distance between the 2 displays.

edit: i just saw
reshade.me/forum/troubleshooting/4658-wo...depth-buffer-flicker

Marty McFly wrote: ReShade disables depth access in multiplayer games (i.e. when ReShade detects network activity from the game) to prevent cheating. So each time WoW produces traffic, your depth buffer is disabled. Nothing you can do about that since custom ReShade builds that don't contain this safeguard don't get whitelisted by anticheat software.


but thats not it! If I am not rotating the camera, and players going around me, no problems, as soon as I start turning...

edit2:
Found the problem!
It was in-game wow options - video - effects - full screen glow effect, located at the bottom.
Although now the depth field is constantly black and not moving, not sure if I have 3D now, hmm.
Last edit: 1 year 5 months ago by tsilliev.

Please Log in or Create an account to join the conversation.