Welcome, Guest.
Username: Password: Remember me

TOPIC: Final Fantasy IV

Final Fantasy IV 1 year 4 days ago #1

I'm having trouble getting Reshade 1.1.0 working on this game though, according to the compatibility list, it should. I've already checked any forced MSAA/SSAA, reset/deleted the entire nvidia profile, and disabled DSR. I've tried both manual and Mediator installs, as well as SweetFX with no luck (and yes, cleaning remnants of each out between attempts). According to the opengl32.log, there are items being hooked, but the normal compilation message in the top left corner for ReShade is not being displayed nor are the effects working.

If it helps at all, the items being hooked according to the log are user32.dll, ws2_32.dll, and opengl32.dll; my pipeline consists of DPX, Curves, Lumasharpen, and SMAA. I've also tried running both the main exe, launcher exe and steam exes in multiple configurations of 'as admin' and not and steam overlay is disabled. Running Windows 10 Pro x64.

Any ideas?
Last Edit: 1 year 4 days ago by cyntech. Reason: New info
The administrator has disabled public write access.

Final Fantasy IV 1 year 4 days ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2458
  • Thank you received: 1394
Could you upload the full log somewhere?
Cheers, crosire =)
The administrator has disabled public write access.

Final Fantasy IV 1 year 4 days ago #3

Here ya go. http://pastebin.com/YYCkZwMg

Something I forgot to mention is that this only gets even this far with all 3 executables running as admin. As an addendum to this: if I launch the game via Steam, it doesn't work whatsoever even as far as hooking-- I actually have to go to the game folder and use FF4.exe to launch the game (though the effects still don't work).
Last Edit: 1 year 4 days ago by cyntech.
The administrator has disabled public write access.

Final Fantasy IV 1 year 3 days ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2458
  • Thank you received: 1394
All very much sounds like FF4.exe is not the actual game executable. I remember from one of the Final Fantasy demos that the executable was hidden in one of the subfolders, so check if you can find any other exes and install ReShade to one of them instead.
Cheers, crosire =)
The administrator has disabled public write access.

Final Fantasy IV 1 year 3 days ago #5

Double checked the folders, just the two executables. FF4.exe and FF4_Launcher.exe, the latter of which I've also tried installing to. No difference, installed to one or the other-- or both.

Log for that is here: http://pastebin.com/WFjpLddB

Something else that I've noticed is that both executables continue running and must continue running whilst the game is on. If FF4_Launcher.exe is closed, FF4.exe is closed with it-- but not vice versa obviously.
The administrator has disabled public write access.

Final Fantasy IV 11 months 4 weeks ago #6

Yeah, never could figure this out. I tried installing ReShade in every folder related to the game including in system32 without luck (don't worry, I fixed it later :P). Not sure why it won't properly load the effects even though it is obviously hooking the video dlls. Tried the current standalone sweetfx package and the older 0.15.0 version ReShade with no luck as well. Unfortunately the user that confirmed this as working didn't leave much info from what I found, besides needing to use the older reshade launcher on the main exe and then the game launcher to get the effects to work. (Which also didn't work for me. Could be a game version difference, but as they didn't list their version, I don't know.)
The administrator has disabled public write access.