[SOLVED] Darwinia, multiple OpenGL contexts, breakage

  • Posts: 2
4 years 3 months ago #1 by Solra Bizna
My fiancee has deuteranopia, and I've been using ReShade to help her play games that would otherwise be intolerable for her. Darwinia, as a game made entirely out of reds, greens, and yellows, is a pretty bad offender. But when I set up ReShade with it, I find that the prosthetic shader works only for a few seconds, then ceases to work.

The log is extremely repetitive, and largely consists of hundreds of kilobytes of this back and forth between contexts 00010001 and 00010000:

Warning: Spoiler! [ Click to expand ]


I'm not sure what to make of this. I tried taking a look at Darwinia's code to see what it's actually doing, but it's UPX'd, and manually unpacking that is more effort than I'd like to expend right now. I can provide the full log if necessary, but it really does almost only consist of... that.

Please Log in or Create an account to join the conversation.

  • Posts: 2
4 years 3 months ago - 4 years 3 months ago #2 by Solra Bizna
Worth mentioning: It works fine on my machine, no matter what I do.

Edit: Ugh. "AMD Gaming Evolved" had managed to get installed without either of us noticing, and was causing the breakage. After we uninstalled it, the problem disappeared.

Edit 2: Since the original report is moot, this thread should probably be deleted. I'd delete it myself if I could.

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 3 months ago - 4 years 3 months ago #3 by crosire
Glad to hear you got it sorted out! =) I'll mark it as solved for future reference.

Please Log in or Create an account to join the conversation.