Path of Exile issue

More
6 years 10 months ago #1 by thechris2233 Path of Exile issue was created by thechris2233
Hi I was hoping someone could offer help with reshade and path of exile. I've tried everything I can find via search but no luck so far. The goal is to use reshade with 3d lut for color corrections, but I can't even get "normal" sweetfx stuff to work.

Graphics are nvidia 980ti with latest driver 361.75
Reshade version: 1.1.10 with sweetfx 2.0
I also tried enbinjector version0004

The game is steam version
I have disabled all overlays but steam

I have tried just setting game up in mediator like normal (it is 32 bit client dx9) but it doesn't not appear to be hooking in
I then tried enbinjector, but it is not hooking here either. I copied enbinjector .exe and .ini to game directory and set enbinjector.ini to
[LIBRARY]
LibraryName=ReShade32.dll

[TARGETPROCESS]
ProcessName0=PathOfExileSteam.exe

However it's still not hooking in. I do have a reshade.log but the entries make no sense to me. The "loaded to" in first line seems to keep changing to whatever newest program I open. Not sure if that's normal or not:
31/01/2016 14:15:43:192 [47896] | INFO  | Initializing crosire's ReShade version '1.1.0.962' built on '2015-11-07 11:55:53' loaded from "C:\Program Files (x86)\Steam\steamapps\common\Path of Exile\ReShade32.dll" to "C:\Program Files (x86)\Evernote\Evernote\Evernote.exe" ...
31/01/2016 14:15:43:234 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d8.dll" ...
31/01/2016 14:15:43:234 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:234 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d9.dll" ...
31/01/2016 14:15:43:234 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:234 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d10.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d10_1.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d11.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\d3d12.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\dxgi.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\opengl32.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Delayed.
31/01/2016 14:15:43:235 [47896] | INFO  | Registering hooks for "C:\Windows\system32\user32.dll" ...
31/01/2016 14:15:43:235 [47896] | INFO  | > Libraries loaded.
31/01/2016 14:15:43:244 [47896] | INFO  | > Found 5 match(es). Installing ...
31/01/2016 14:15:43:294 [47896] | INFO  | > Installed 5 hook(s).
31/01/2016 14:15:43:294 [47896] | INFO  | Registering hooks for "C:\Windows\system32\ws2_32.dll" ...
31/01/2016 14:15:43:294 [47896] | INFO  | > Libraries loaded.
31/01/2016 14:15:43:296 [47896] | INFO  | > Found 8 match(es). Installing ...
31/01/2016 14:15:43:382 [47896] | INFO  | > Installed 8 hook(s).
31/01/2016 14:15:43:382 [47896] | INFO  | Initialized.

Any ideas?

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #2 by thechris2233 Replied by thechris2233 on topic Path of Exile issue
So I restarted from scratch. Same issue but no log now. Not sure what I did to cause that previously. So far it looks like it's just not able to load in. Other games work fine so I'm out of ideas.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #3 by SpinelessJelly Replied by SpinelessJelly on topic Path of Exile issue
Just tried my old installation with Reshade 0.19.2 and enbinjector and it still works fine (the loading screen takes forever though). If you find it impossible to use the latest version of Reshade you can check older builds here reshade.me/forum/general-discussion/294-reshade-repository#2182

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #4 by thechris2233 Replied by thechris2233 on topic Path of Exile issue

SpinelessJelly wrote: Just tried my old installation with Reshade 0.19.2 and enbinjector and it still works fine (the loading screen takes forever though). If you find it impossible to use the latest version of Reshade you can check older builds here reshade.me/forum/general-discussion/294-reshade-repository#2182


Interesting. I'll give that a shot. Was that with or without the framework? (I'm not sure it even matters)

edit: Another question. Do you just have reshade32.dll in the main directory or did you do the bit where you rename it to d3d9? Thanks!
Last edit: 6 years 10 months ago by thechris2233.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #5 by thechris2233 Replied by thechris2233 on topic Path of Exile issue
So I retried version ReShade 0.19.2 Public Beta with Framework, and it works!

Now here's the really weird part. I renamed ReShade.fx, ReShade32.dll, and the Reshade folder, copied in those items from newest version of ReShade...and it still works!

So I have no Bleeping idea what changed to make it start loading...but it works now. So weird. So for step by step of others having problems, try this.

1. Download Reshade 0.19.2 Public Beta with Framework
2. Download ENBinjector (im using version 0004)
3. Copy ReShade Folder, Reshade32.dll, and ReShade.fx to Path of Exile folder
4. Copy ENBinjector.exe and ENBinjector.ini to Path of Exile folder
5. Edit ENBinjector.ini. I just added the line for POE and updated the library. Mine looks like this:
[LIBRARY]
LibraryName=ReShade32.dll

[TARGETPROCESS]
ProcessName0=tesv.exe
ProcessName1=SkyrimLauncher.exe
ProcessName2=CreationKit.exe
ProcessName3=PathOfExileSteam.exe
ProcessName4=
ProcessName5=
ProcessName6=
ProcessName7=
ProcessName8=
ProcessName9=
ProcessName10=
ProcessName11=
ProcessName12=
ProcessName13=
ProcessName14=
ProcessName15=

6. Run ENBinjector as admin and leave it running
7. Start Path of Exile and you should see crosire welcome message.
8. (optional) Then if that works copy newer .dll files, .fx, and reshade library over old one
Note newer one may "just" work...no idea- it wasn't for me (but the steps above worked)

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.