[SOLVED] TS4 64bit + depth buffer

6 years 3 months ago #1 by amoebae
TS4 64bit + depth buffer was created by amoebae
The Sims 4 recently released a 64bit version, and the depth buffer isn't accessible in it. Prior to that, I'd been able to get depth buffer access using ReShade+Framework 1.0+ and the game's 32bit exe.

I've tried going back to the 32bit exe, but now I can only get ReShade to work using the 64bit dll with it - which seems very odd to me but there you go. And as expected, no depth buffer.

(And just for shizz and giggles I tried the 32bit dll with the 64bit exe, with predictable results.)

I don't have the skills to troubleshoot this myself, so wondered if anyone had any ideas, or if I should just give it up as a bad job?

(Someone told me some 64bit games have had depth buffer problems in the past. I haven't hit any problems in other games myself, but I guess this could just be that?)


Please Log in or Create an account to join the conversation.

6 years 3 months ago #2 by amoebae
Replied by amoebae on topic TS4 64bit + depth buffer
It's suddenly working.

Depth buffer wasn't working with 1.1.0, with 64bit or 32bit exe and either dll.

I tried 1.0.0 - that I knew was working with the 32bit exe before the patch, but that didn't work either.

In the process, notepad++ accidentally updated or didn't update a couple of the cfg files I had open while I was testing.

Even though I'd reinstalled 1.1.0 (with no depth buffer access), notepad++ - when asking to reload the files because they'd changed - somehow used a different one (I could tell because everything looked weird).

So I pasted in the 1.1.0 files as they should be, back to the bin folder, and boom - AO and DoF.

These are the exact same files I was using earlier when the depth buffer wouldn't work.

Anyway, problem solved for now. Somehow. Wish I could say how.

Please Log in or Create an account to join the conversation.