[SOLVED] S.T.A.L.K.E.R. CoP/CoC shader error (Reshade 2.0)

More
4 years 5 months ago #1 by bearbearbear
Starting a new playthrough on Call of Chernobyl so I decided to use the 2.0 version of Reshade for it.
There seems to be one minor issue so far however. Whenever I enable Ganossa's LENSDIRT shader, I get this error back:

D:\My Documents\Modding\Reshade\ReShade/Shaders/Ganossa/Bloom.fx(54, 21): error X3011: value must be a literal expression

It seems to be only this shader that's causing the compilation to fail. Is there a simple fix I might be missing or is this something bigger?
Thank you in advance!

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #2 by crosire
Nothing wrong on your part. There seems to be a bug in the ReShade FX compiler, which causes constant expressions to fail compilation. I'll look into it.
The following user(s) said Thank You: bearbearbear

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #3 by bearbearbear
Replied by bearbearbear on topic S.T.A.L.K.E.R. CoP/CoC shader error (Reshade 2.0)
Thank you! Hopefully it's not too big of an issue to fix for you.
Last edit: 4 years 5 months ago by bearbearbear. Reason: spelling error

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #4 by Alexander_B
Replied by Alexander_B on topic S.T.A.L.K.E.R. CoP/CoC shader error (Reshade 2.0)
I received this error not only with Bloom.fx, but with Ganossa/AmbientLight.fx too.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #5 by crosire
I've seen multiple reports of this now, but I'm not able to reproduce it. Could somebody please share a config with which this happens?
Last edit: 4 years 5 months ago by crosire.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6 by Wicked Sick

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #7 by crosire
I still don't get any errors with it.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #8 by Wicked Sick
Replied by Wicked Sick on topic S.T.A.L.K.E.R. CoP/CoC shader error (Reshade 2.0)
If it helps, i am on Windows 10 x64. Also, perhaps some of the people here should test my upload and see if it generates the error for them. With which game did you try it, Crosire?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #9 by crosire
One Direct3D 9 and one Direct3D 11 game. But all that should not matter. This is an error from the ReShade FX compiler which is independent of OS and API.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #10 by Wicked Sick
Replied by Wicked Sick on topic S.T.A.L.K.E.R. CoP/CoC shader error (Reshade 2.0)
I understand. I asked because I have used this file with Borderlands 2 and it was ok, then with Trine 3 and I got this error. I was thinking that, perhaps, it was something particular to a certain game. Like Thief is.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #11 by lowenz
Don't play CoP in D3D11. You got the tesselation, right, but the levels use D3D8 light positions and values (see campfire lights). It's a known bug. Or find a fix for that (manually fix the values).
The best option is to play with D3D10 rendering path (and maxed out).
Last edit: 4 years 5 months ago by lowenz.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #12 by crosire
Finally managed to reproduce the error. Will look into it.
Last edit: 4 years 5 months ago by crosire.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #13 by crosire
Fixed in the next update.
The following user(s) said Thank You: bearbearbear

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #14 by Maegirom
I have found this issue in Ganossa UIMask. I'm trying to mask UI in fallout 4 after applying DOF and I receive this error.

Please Log in or Create an account to join the conversation.