Welcome, Guest.
Username: Password: Remember me

TOPIC: Far Cry 2 + Reshade on win 10

Far Cry 2 + Reshade on win 10 7 months 1 week ago #1

Freezes on the initial popup. Tried both dx9 and dxgi.
directx_Jun2010_redist.exe unpacked and installed.
Can't get why it doesn't launch.
dxgi.log
Warning: Spoiler! [ Click to expand ]

d3d9.log
Warning: Spoiler! [ Click to expand ]


UPDATE:
Renaming dxgi.dll to d3d11.dll made the game move past the popup and work , but the effects don't load. (I presume because the game has no support for dx11?)
Last Edit: 7 months 1 week ago by WorkingRobot.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2453
  • Thank you received: 1393
There is a setting in the game to switch between DirectX 9 and 10 as far as I know. I don't know if it has any effect on the game at all, but what is that one set to?
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: WorkingRobot

Far Cry 2 + Reshade on win 10 7 months 1 week ago #3

I tried both settings with all dll names.
With dxgi.log I used dx10
With d3d9.log I used dx9
Last Edit: 7 months 1 week ago by WorkingRobot.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #4

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 139
  • Thank you received: 113
As far as I remember it only works with d3d9. You have to set the ingame option to dx9, quit and THEN copy reshades dll (d3d9.dll) into the bin folder. Switching between the modes with a present dll doesn't work somehow.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #5

Unfortunatly this solution doesn't work.
First time I launched it it was already in dx9 mode because I saw that FC2+reshade works in dx9 only on the compatability list.

Also it seems that I included worng d3d9.log in my initial post
here's the log from the correct dll:
Warning: Spoiler! [ Click to expand ]
Last Edit: 7 months 1 week ago by WorkingRobot.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #6

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2453
  • Thank you received: 1393
It still doesn't use DirectX 9 according to the log. Tries all kinds of DirectX 10+ initialization, but never once DirectX 9.
Cheers, crosire =)
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #7

Checked the config files, it says that the game is in dx9 mode.
Platform="d3d9"
Windows 10 falut?
Going to continue poking around in config files and registry, maybe there's some other line that cancels this one out.

Update:
Found two lines so far.
DepthPassQuality="d3d10" -This one changes nothing. Game still freezes during the splash screen.
id="customd3d10" -There was no point for changing this one since it was obvious that it's the name of the custom preset for dx10, but I changed it anyway. No results.

Update2:
Out of despereation removed a bunch of dlls out of bin folder such as Microsoft.DirectX.Direct3D.dll, Microsoft.DirectX.Direct3DX.dll and Microsoft.DirectX.dll.
Wierdly, game works fine without them. Their absence even made Creative Alchemy kick in, but still... No positive result in therms of geting past the splash screen with Reshade in the bin folder.

Update3:
Downloaded the GES preset and took the dxgi.dll out of there. From what I remember it was specifically included there to force the game to dx9 mode, and that actually seems to be the case. When I open display settings with GES dxgi installed, the option to choose the DirectX version isn't there anymore.
Tried the GES dxgi.dll with reshade and here's the result:
Warning: Spoiler! [ Click to expand ]

It tries to initialise dx9 once this time... Then it goes straight to dx11 and dx12.
Last Edit: 7 months 1 week ago by WorkingRobot.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #8

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 139
  • Thank you received: 113
I've verified this. The last version that works is ReShade 0.18.3. Here are the logs with 0.18.3 (working) and 2.0.3f1 (not working)

WorkingRobot, you can download legacy versions of ReShade here.

edit: maybe the versions 18.4 -19.0 also work. I haven't tested these.
Last Edit: 7 months 1 week ago by brussell.
The administrator has disabled public write access.
The following user(s) said Thank You: WorkingRobot

Far Cry 2 + Reshade on win 10 7 months 1 week ago #9

I will test them when I come back home. Thank you.

Update:
Tested only the one you said is defenetly compatible, and it doesn't seem to work at all. On which version of windows have you tested it?
Warning: Spoiler! [ Click to expand ]
Last Edit: 7 months 1 week ago by WorkingRobot.
The administrator has disabled public write access.

Far Cry 2 + Reshade on win 10 7 months 1 week ago #10

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 139
  • Thank you received: 113
Windows7 64bit. Since newer versions of ReShade doesn't work I've assumed that you have the same problem. But maybe it's really Win10 specific.

ps: the last working release (at least on Win7) is 0.19.0.
pps: the dx10 mode also works with d3d9.dll (using dxgi.dll doesn't work)
The administrator has disabled public write access.
The following user(s) said Thank You: WorkingRobot