Welcome, Guest.
Username: Password: Remember me

TOPIC: [Solved] Identical Computers, different results

[Solved] Identical Computers, different results 11 months 2 weeks ago #1

  • Roj
  • Roj's Avatar
  • Offline
  • Posts: 2
I have two almost identical computers (only hardware difference is video cards, R9 270X vs HD7850, same AMD drivers installed). Both running Win10 64bit. Both have DX9 installed manually. Both with latest version of Reshade. Reshade and Guild Wars folders are identical, in identical locations.

On my computer Reshade works fine with Guild Wars 2. On the other computer, no effect. Here is a copy of the log file on that other computer:

06/06/2016 15:04:22:807 [03956] | INFO | Initializing crosire's ReShade version '2.0.3.1121' built on '2016-04-03 19:21:12' loaded from "C:\Guild Wars 2\d3d9.dll" to "C:\Guild Wars 2\Gw2.exe" ...
06/06/2016 15:04:22:884 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d8.dll" ...
06/06/2016 15:04:22:884 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:884 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d9.dll" ...
06/06/2016 15:04:22:884 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:884 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10.dll" ...
06/06/2016 15:04:22:885 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:885 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10_1.dll" ...
06/06/2016 15:04:22:885 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:885 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d11.dll" ...
06/06/2016 15:04:22:885 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:885 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d12.dll" ...
06/06/2016 15:04:22:885 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:885 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\dxgi.dll" ...
06/06/2016 15:04:22:886 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:886 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\opengl32.dll" ...
06/06/2016 15:04:22:886 [03956] | INFO | > Delayed.
06/06/2016 15:04:22:886 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\user32.dll" ...
06/06/2016 15:04:22:886 [03956] | INFO | > Libraries loaded.
06/06/2016 15:04:22:887 [03956] | INFO | > Found 5 match(es). Installing ...
06/06/2016 15:04:22:984 [03956] | INFO | > Installed 5 hook(s).
06/06/2016 15:04:22:984 [03956] | INFO | Registering hooks for "C:\WINDOWS\system32\ws2_32.dll" ...
06/06/2016 15:04:22:985 [03956] | INFO | > Libraries loaded.
06/06/2016 15:04:22:985 [03956] | INFO | > Found 8 match(es). Installing ...
06/06/2016 15:04:23:135 [03956] | INFO | > Installed 8 hook(s).
06/06/2016 15:04:23:135 [03956] | INFO | Initialized.
06/06/2016 15:04:23:135 [03956] | INFO | Redirecting 'Direct3DCreate9(32)' ...
06/06/2016 15:04:23:138 [03956] | INFO | Installing delayed hooks for "C:\WINDOWS\system32\d3d9.dll" ...
06/06/2016 15:04:23:138 [03956] | INFO | > Found 9 match(es). Installing ...
06/06/2016 15:04:23:138 [03956] | INFO | > Installed 9 hook(s).
06/06/2016 15:04:23:175 [03956] | INFO | Exiting ...
06/06/2016 15:04:23:175 [03956] | INFO | Uninstalling 27 hook(s) ...
06/06/2016 15:04:23:502 [03956] | INFO | Exited.

On my computer identical up to the "Exited" line. On mine, instead of "Exited", it continues with:

06/06/2016 16:58:35:549 [01688] | INFO | Installing delayed hooks for "C:\WINDOWS\system32\d3d11.dll" (Just loaded via 'LoadLibraryW("ole32.dll")') ...
06/06/2016 16:58:35:549 [01688] | INFO | > Found 2 match(es). Installing ...
06/06/2016 16:58:35:593 [01688] | INFO | > Installed 2 hook(s).
06/06/2016 16:58:35:593 [01688] | INFO | Installing delayed hooks for "C:\WINDOWS\system32\d3d12.dll" (Just loaded via 'LoadLibraryW("ole32.dll")') ...
06/06/2016 16:58:35:593 [01688] | INFO | > Found 1 match(es). Installing ...
06/06/2016 16:58:35:615 [01688] | INFO | > Installed 1 hook(s).
06/06/2016 16:58:35:615 [01688] | INFO | Installing delayed hooks for "C:\WINDOWS\system32\dxgi.dll" (Just loaded via 'LoadLibraryW("ole32.dll")') ...
06/06/2016 16:58:35:615 [01688] | INFO | > Found 7 match(es). Installing ...
06/06/2016 16:58:35:765 [01688] | INFO | > Installed 7 hook(s).
etc.
plus lots of other detailed stuff...

Any ideas of what is going wrong?
Last Edit: 9 months 2 weeks ago by Roj. Reason: Solved
The administrator has disabled public write access.

Almost identical Computers, different results 11 months 15 hours ago #2

  • Roj
  • Roj's Avatar
  • Offline
  • Posts: 2
Solved!

For Reshade to work with Guild Wars 2, it seems to require the "-nopatchui" command line argument.

However, there seems to be an incompatibility between the "-nopatchui" and "-autologin" arguments - GW2 doesn't reach its opening screen when both of those are on the command line (or takes forever - I didn't wait)

If you want autologin to work with Reshade, however, you just have to include the "-username", "-password", and the "-nopatchui" commands on the command line.

Note that the "-nopatchui" command basically just hides the initial startup stuff (the login screen and the updating screen), so it can take a long time to get to the character screen, especially when a patch is being updated.
The administrator has disabled public write access.