ReShade with FSX-SE (DX10)

  • Posts: 1
4 years 2 weeks ago - 4 years 2 weeks ago #1 by fcisuperguy
Hi,

I've recently been contemplating adding ReShade to FSX to make it look more realistic. Installing ReShade goes fine (I renamed ReShade32.dll to dxgi.dll); however, when I try and launch FSX alongside any application that interacts with it (ex. vPilot) when FSX is loaded (in flight), FSX stops responding. Event viewer shows this error:

Faulting application name: fsx.exe, version: 10.0.62615.0, time stamp: 0x559f9a9a
Faulting module name: mfc120.dll, version: 12.0.21005.1, time stamp: 0x524fabbd
Exception code: 0xc0000005
Fault offset: 0x0024c8ab
Faulting process id: 0x19d4
Faulting application start time: 0x01d1c9fa1c982a6e
Faulting application path: D:\Steam\steamapps\common\FSX\fsx.exe
Faulting module path: C:\WINDOWS\SYSTEM32\mfc120.dll
Report Id: 3f5289c9-a754-40c0-b024-2edb8e9df497
Faulting package full name:
Faulting package-relative application ID:


I've already verified my system files with 'sfc /scannow' in an elevated command prompt. No violations were found. I've also manually replaced the files with equivalents from another computer, to no avail. Any ideas on how to fix this?

Please Log in or Create an account to join the conversation.

  • Posts: 3
3 years 10 months ago #2 by CaptKornDog1
What version of ReShade did you use?

I'm trying to get ANY version to work with FSX:SE and DX10. Either the sim won't start, crashes on the intro splash screen, or crashes when I click free flight.

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 years 10 months ago #3 by deadmanwalking

CaptKornDog1 wrote: What version of ReShade did you use?

I'm trying to get ANY version to work with FSX:SE and DX10. Either the sim won't start, crashes on the intro splash screen, or crashes when I click free flight.


had the same problem, i assume you use dx10fixer, bcoz i'm using it and FSX won't start. then i revert back to dx9, renaming to d3dx9.dll, and FSX manage to run.
my problem is that the splitscreen not shown eventhough i already set value to 1.

i tried with the same config into other game and the splitscreen shows. i haven't change other value since i only want to know if the splitscreen work then other will work.

Please Log in or Create an account to join the conversation.