Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade not working with WOW

Reshade not working with WOW 1 year 1 month ago #1

I installed everything properly. When I try to enable HDR for example, nothing happens. Nothing happens with all of them. Just seems like the mediator isn't applying the changes. I do see the display of the reshade when I launch wow. I copied and pasted the 64 bit ddl file and move it over to the wow directory. I tried setting DX to 9 in WOW along with the shade DX set at 9. I did it for 11 as well. Still nothing.

There is a log file, so the program is loading, I'm assuming.

Any ideas how I can get this to work?

I was able to get the reshader w/ sweetfx to work (under alternate download) but not the Reshader with framework.
The administrator has disabled public write access.

Reshade not working with WOW 1 year 3 weeks ago #2

Same issue here. Both windows 10 & 8.1. I'm hoping somebody is looking into this, or atleast a reply.
The administrator has disabled public write access.

Reshade not working with WOW 1 year 3 weeks ago #3

  • sycler
  • sycler's Avatar
  • Offline
  • Posts: 2
  • Thank you received: 1
I also have this problem but only with Sweetfx 2.0 or 1.5 and etc. The log does say its running, but at character selection entering the world causes WOW to crash. Error report in the blizzard files state Access Violation. I tried everything from deleting interface,addons,cache,wtf folder and nothing works.

Only removing d3d11 from the wow folder allows the game to run without sweetfx. Renaming it dxgi.dll makes the game not launch at all.

Reshade with Framework runs just fine for me when using d3d11.

Windows 7 user.
Last Edit: 1 year 3 weeks ago by sycler.
The administrator has disabled public write access.

Reshade not working with WOW 1 year 3 weeks ago #4

  • sycler
  • sycler's Avatar
  • Offline
  • Posts: 2
  • Thank you received: 1
Writing this in case someone is stuck. Some of these steps may or may not be mandatory for this is what I did to get it running. After a lot of troubleshooting and tinkering I found some steps that might help someone else.

Reshade Framework and Sweetfx work fine with WOW. The issue is wow itself or what you have added to the game such as addons. If you are using and Interface changing huds this will almost certainly be the main problem. This is what i did :

1. Repair game ability from the wow options in the launcher. For me this found 'something' missing.

2. Delete wtf,addons,cache, and follow these steps:

3. us.battle.net/support/en/article/deletin...U&utm_content=050713

4. Once that is done, use task manager and ensure that nothing of blizzard is running in the background.

Simply closing the launcher and exiting game is not sufficient. One of the problems I had was a process known as Agent.32 that would stay open (32 bit launcher I'm assuming?). It messed up fresh installs of Reshade/Sweet FX.

5. I restarted my computer for good measure.

6.Install reshade/sweetfx. Rename the DLL to d3d11.

7. Launch the game with the 64 bit exe only. The launcher would mess things up.

If you can launch with no problems and finally enter the world you will need to go through your addons to see who the culprit might be. In my case it was ElvUI. This addon would do an in-game install that changed the CVAR numbers. I believe this was a huge problem because skipping that part of the install allows me to use the adddon. Not skipping and the game would crash next time you enter the world. This was tricky because simply uninstalling the addon would not reverse internal numbers done to the config of wow. I have not had a single crash in 20 hours of play over 3 days.

Hope this poorly written info helps someone who was desperate like me.
Last Edit: 1 year 3 weeks ago by sycler.
The administrator has disabled public write access.
The following user(s) said Thank You: ldylarke