Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Something strange in Borderlands 2

Something strange in Borderlands 2 2 years 7 months ago #1

I know BL 2 is listed as a working game but I'm running into a problem with it. When I first launch the game it seems fine, showing the first vid, but then the screen goes black and stays that way. I can click the screen/press a button to continue, so the "press button to continue" screen is there but isn't showing. It then goes to the options screen, which is normal for a second but then the options disappear. I can still select the options, however, by clicking where they were so it seems overlay/hud related. Once in the game there is a black outline of the mountains/scenery that, I believe, is still from the first loading screen and, if I click escape to try and leave, none of the options are there, just like before. And, just like before, I can still click them, if I can find them, so they are "there" but just aren't showing up.

I'm using version 14 with SweetFX. It's working great on Battlefield 4 ( I can't believe I waited this long to switch. I finally got SFX working consistently with BF4 on Windows 8.1 so I was hesitant to mess with it. Damn, it is really amazing how good this looks ) and working with Far Cry 3 and Metro 2033 ( though it does give a strange error with Metro at the top of the screen in yellow text when the game starts ).

If anyone else has had this problem with BL 2 I'd appreciate some help. Thanks.
The administrator has disabled public write access.

Something strange in Borderlands 2 2 years 7 months ago #2

  • ScarecrowDM
  • ScarecrowDM's Avatar
  • Offline
  • The HUE Maker
  • Posts: 22
  • Thank you received: 6
I was playing Borderlands 2 just about 10 minutes ago and it is working fine for me, dude.

Which shaders do you have on? Pass your settings, maybe I'm able to reproduce.

I'm also using Windows 8.1, paired with a R9 280X (14.12).
The administrator has disabled public write access.

Something strange in Borderlands 2 2 years 7 months ago #3

I haven't messed with the ReShade shaders yet, I've just been leaving those as is ( I'm not even sure if I can change them, I just really started messing with it. I'm so used to just using SweetFX and nvidia inspector... ). The SweetFX preset I'm using is sfx.thelazy.net/games/preset/142/ though I've tried it with others also so I'm fairly certain it's not due to the sweetfx setting ( I'm changing the values in the settings.txt that came with 2.0 so they're consistent with the new version ). Other that messing with that, I'm just dragging the reshade files over and renaming the dll.

Thanks for your help, it's really annoying me that I can't figure this out on my own.

edit: Here's my d3d9.log in case it helps: pastebin.com/WdPFf1CX

edit: I finally figured it out. I was trying to override the AA thru the drivers, via nvidia inspector, and that seemed to be the cause of the problem. Once I set it back to "Application Controlled" it works and looks great. Thanks!
Last Edit: 2 years 7 months ago by cstarkey42. Reason: solved
The administrator has disabled public write access.

Something strange in Borderlands 2 2 years 7 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2779
  • Thank you received: 1577
Great to hear you got it solved and thanks for reporting back =)
Cheers, crosire =)
The administrator has disabled public write access.