Welcome, Guest.
Username: Password: Remember me

TOPIC: Dark Souls (Steam) My Sweet FX not so sweet :(

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 2 weeks ago #1

Hi there! So I just got the pc version of Dark Souls (Been playing it mostly on ps3 so far) and after installing the DSfix and fiddling with its options i was very pleased with effects, the game looks so much better. Then I installed few texture makeovers from nexus mods and got even better effects. Then I found some nice Sweet FX settings and decided to push on with the visual improvements. I downloaded what i suppose is the newest version of the Reshade/Sweet FX from this site, and then used the installer as per instructions. Then I applied the cinematic preset via nexus mods. I turned off the anti aliasing option for DSfix as well as the in game anti aliasing. I launched the game and got welcomed by the Sweet fx text and all. I loaded my game only to find my graphics are all white and i cant see anything. After I pressed the scroll lock to see if there will be any difference not much changed the whiteness got slightly darker if im correct. I tried different preset after uninstalling the first one and this time i actually got to see the game but the graphics were all weird with weird looking fog in the distance and multiple copies of my character (by copies i mean sort of fading afterimages of the contours of my character and some other objects) I'm an average user with only basic knowledge of modding and I'm sad to admit that this is beyond me. Any clues please? I got strong machine, and would love to enjoy the game in its full glory and capabilities via sweet fx.
Last Edit: 11 months 2 weeks ago by Yukiwo. Reason: Typos
The administrator has disabled public write access.

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 2 weeks ago #2

  • crosire
  • crosire's Avatar
  • Online
  • Posts: 2780
  • Thank you received: 1581
SweetFX is deprecated and no longer supported. Please use ReShade 3.0 instead.
Cheers, crosire =)
The administrator has disabled public write access.

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 1 week ago #3

Ahh, thanks for reply. I downloaded this: "ReShade_Setup_3.0.1.exe" and installed by providing path to my Dark Souls.exe and selected Direct3D 10+ (I'm on DX11, figured that would be the right choice) i then launched the game to see if there is any change, like when I did the same with a similar installer for Sweet FX before, but couldn't tell the difference. What am I missing? I tried searching the forums for a tutorial for noobs, but couldn't find anything. Would you kindly point me towards any place where I can find a step by step instructions please? i read some bits of informations and the readmes but I'm still confused. I really did my best to try to figure this out by myself but this is it. Help please or just give me some hints at least :/
The administrator has disabled public write access.

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 1 week ago #4

  • crosire
  • crosire's Avatar
  • Online
  • Posts: 2780
  • Thank you received: 1581
AFAIK the game uses Direct3D 9, so choose that. That selection is not about what your hardware supports, but what the game uses for rendering. The rest is pretty self explanatory after successful installation. ReShade will greet you once you launch the game.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Yukiwo

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 1 week ago #5

I'm so dumb! :( Thanks!

Ok i got it! cant believe i made such a stupid mistake.. After it finished loading effects and what not. I got some errors, about how it cannot open a bunch of files. I fiddled with few effects, and most of them seem to work or at least do something, although, some of them like FXAA makes the game very dark, didn't think anti aliasing should do that? Dunno. Would you like to see the log with those few errors?
Last Edit: 11 months 1 week ago by Yukiwo. Reason: Trying to keep it tidy!
The administrator has disabled public write access.

Dark Souls (Steam) My Sweet FX not so sweet :( 11 months 1 week ago #6

Sorry, I will just bump once if that's ok? Just because I edited my last post in ,to the previous one, and maybe it was unseen? I would really appreciate any help I could get, to get it running properly..
The administrator has disabled public write access.