Welcome, Guest.
Username: Password: Remember me

TOPIC: Issues with Warframe

Issues with Warframe 2 years 3 months ago #1

So I have been trying to get reshade working with warframe for a few days now. Before reshade, I was using sweetfx with warframe perfectly fine through radeon pro. But when I try to get reshade to work with warframe, I just won't work for whatever reason. It doesn't crash or anything, it just won't work. I can even get the initial yes/no warning upon first use to show up, but once in game no white text shows up in the top left corner like it does for other games, and no changes can be seen to the visuals. I got reshade working for other games, just not this one. I have tried other people's reshade settings that work for them in warframe, and still the same issue. I am on windows 8.1 and a 660 ti, and i tried checking dx 10 only and dx11 only for the launcher, and still no go. I turned off all overlays that I have, including steam and no go still. Only thing in the log that is different from the ones from games that work mention something about skipping swap chain because it was created without a hooked d3d device. Any help would be appreciated, thanks.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2644
  • Thank you received: 1517
That exact log message is the problem. Mind posting a full tracelog also? It adds a few useful information to why. =)
Cheers, crosire =)
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #3

www.mediafire.com/download/b8yvtsarm486xnk/dxgi.tracelog

Link to tracelog is below, let me know if anything else is needed.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2644
  • Thank you received: 1517
Try and rename it to "d3d11.dll" instead of "dxgi.dll". That may prevent the game from starting, but it could work if it doesn't.
Cheers, crosire =)
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #5

Doesn't crash, but same thing happens as when it is named dxgi.dll, no white text, no effects, but log is different. Tracelog is below:

www.mediafire.com/download/tkjmzdk54kn2lb6/d3d11.tracelog
Last Edit: 2 years 3 months ago by keefypants.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #6

I have this working for me perfectly, but I run my game in 64bit, all launcher options on except for dx10.
Warning: Spoiler! [ Click to expand ]

Small picture of my folder from warframe with steam. (probably irrelevant)
Warning: Spoiler! [ Click to expand ]

It doesn't have the Trace stuff, but seem'd the same to my eyes when I was comparing the files.
A thing that I noticed is that yours isn't loading the sweet.fx file ... but what do I know about this !? (nothing) so I don't really know if that is the problem.
Corsire should compare the logs and see what is actually diferent
Last Edit: 2 years 3 months ago by Yazame.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #7

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2644
  • Thank you received: 1517
As said, he already posted the problem in the first post. ReShade fails to hook D3D11 (it simply doesn't figure out it is loaded), only hooks DXGI and thus aborts. I downloaded the game, so I can do some testing myself later.

EDIT. Tried now, but it works perfectly fine here too. Put it into the main Warframe folder (where Warframe.exe and Warframe.x64.exe are) and rename it to dxgi.dll.
Cheers, crosire =)
Last Edit: 2 years 3 months ago by crosire.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #8

crosire wrote:
As said, he already posted the problem in the first post. ReShade fails to hook D3D11 (it simply doesn't figure out it is loaded), only hooks DXGI and thus aborts. I downloaded the game, so I can do some testing myself later.

EDIT. Tried now, but it works perfectly fine here too. Put it into the main Warframe folder (where Warframe.exe and Warframe.x64.exe are) and rename it to dxgi.dll.

Yeah thats where I put it before. Unfortunately it seems that it works for most people but there's a handful that it just simply wont work. Its weird that I get the warning yes/no message, but nothing else and no crashes.
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #9

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2644
  • Thank you received: 1517
Are there any overlays (Afterburner, ...), recording software (Fraps, ...), streaming software (OBS, ...), game boosters (Razer Game Booster, ...) or similar running? Any driver forced AA enabled?
Cheers, crosire =)
The administrator has disabled public write access.

Issues with Warframe 2 years 3 months ago #10

crosire wrote:
Are there any overlays (Afterburner, ...), recording software (Fraps, ...), streaming software (OBS, ...), game boosters (Razer Game Booster, ...) or similar running? Any driver forced AA enabled?

No overlays on, no streaming stuff or boosters installed, and used nvidia inspector to restore to profile defaults and turned off any forced aa, and unfortunately nothing.
The administrator has disabled public write access.

Issues with Warframe 2 years 2 months ago #11

Just an update: It apparently works every 1 out of 10 times I start up the game. I can start and quit the game a dozen times, and it will randomly work one or two times. No changes in settings, nothing; just start up the game and hope I get lucky.
The administrator has disabled public write access.