RS2.0: disable specific effects of a prst = error!

More
6 years 4 weeks ago #1 by Nanocrystal RS2.0: disable specific effects of a prst = error! was created by Nanocrystal
Hello,

I'm new here to RS forums. I've tried some presets by other users written for the older version of RS (version 2.0). Now I want to disable *specific* effects I don't really like for a certain preset. But whenever I do this (via ReShade Assistant -> Preset -> Shader List, e.g. disabling "Film Grain"), RS2.0 fails to compile the preset (e.g. error 3000 or 3004, "syntax error" for "vibrance.h", etc.). I'll then have to re-copy all original .cfg-files of that preset to ReShade\Presets\[Preset Name]\ in order to get it to work again!

Is that normal? Can I "cut out" the undesired effects from the .cfg-files (e.g. simply deleting certain lines of code)? Or another solution?

As stated in my previous post, I cannot get these presets to work with RS3.0.4 ...

Thx,

NC

Please Log in or Create an account to join the conversation.

More
6 years 4 weeks ago #2 by Nanocrystal Replied by Nanocrystal on topic RS2.0: disable specific effects of a prst = error!
Here is the error code:

ReShade 2.0.3\ReShade/Shaders/CeeJay\SharedShader\Vibrance.h(64, 64): error X3000: syntax error: unexpected '*'

I tried removing unwanted effects from Pipeline.cfg and I changed their value from "1" to "0" (Tiltshift @ Ganossa.cfg, YACA @ MartyMcFly.cfg)

I also tried adding the #undef (" #undef USE_Tiltshift ", " #undef USE_YACA ") command right above the " #define USE_[EFFECT] " line @ the above mentioned cfg files - that didn't work, too...

NC

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.