Welcome, Guest.
Username: Password: Remember me

TOPIC: ArmA 3 Crash

ArmA 3 Crash 1 year 9 months ago #1

Hi there,

I'm tryin' to run Arma 3 MER: Filmic (sfx.thelazy.net/games/preset/2912) and everytime when I try to launch the game with the preset it crashes. I've disabled Fraps, Seteam Overlay etc. nothing. Nothing happens.

Also here's the log file generated by dxgi.dll
28/02/2015 11:58:06,918 | INFO | Initializing Crosire's ReShade version '0.13.1.665' built on '2015-01-21 20:07:07' loaded from "Z:\Program Files (x86)\steamapps\common\Arma 3\dxgi.dll" to "Z:\Program Files (x86)\steamapps\common\Arma 3\arma3.exe" ...
28/02/2015 11:58:06,933 | INFO | Registering hooks for "C:\Windows\system32\d3d8.dll" ...
28/02/2015 11:58:06,933 | INFO | > Delayed.
28/02/2015 11:58:06,933 | INFO | Registering hooks for "C:\Windows\system32\d3d9.dll" ...
28/02/2015 11:58:06,933 | INFO | > Delayed.
28/02/2015 11:58:06,933 | INFO | Registering hooks for "C:\Windows\system32\d3d10.dll" ...
28/02/2015 11:58:06,933 | INFO | > Libraries loaded.
28/02/2015 11:58:06,933 | INFO | > Found 2 match(es). Installing ...
28/02/2015 11:58:06,933 | INFO | > Installed 2 hook(s).
28/02/2015 11:58:06,933 | INFO | Registering hooks for "C:\Windows\system32\d3d10_1.dll" ...
28/02/2015 11:58:06,933 | INFO | > Delayed.
28/02/2015 11:58:06,933 | INFO | Registering hooks for "C:\Windows\system32\d3d11.dll" ...
28/02/2015 11:58:06,933 | INFO | > Libraries loaded.
28/02/2015 11:58:06,933 | INFO | > Found 2 match(es). Installing ...
28/02/2015 11:58:06,949 | INFO | > Installed 2 hook(s).
28/02/2015 11:58:06,949 | INFO | Registering hooks for "C:\Windows\system32\dxgi.dll" ...
28/02/2015 11:58:06,949 | INFO | > Delayed.
28/02/2015 11:58:06,949 | INFO | Registering hooks for "C:\Windows\system32\opengl32.dll" ...
28/02/2015 11:58:06,949 | INFO | > Delayed.
28/02/2015 11:58:06,949 | INFO | Registering hooks for "C:\Windows\system32\ws2_32.dll" ...
28/02/2015 11:58:06,949 | INFO | > Libraries loaded.
28/02/2015 11:58:06,949 | INFO | > Found 8 match(es). Installing ...
28/02/2015 11:58:06,996 | INFO | > Installed 8 hook(s).
28/02/2015 11:58:06,996 | INFO | Initialized.
28/02/2015 11:58:06,996 | INFO | Installing delayed hooks for "C:\Windows\system32\dxgi.dll" ...
28/02/2015 11:58:07,011 | INFO | > Found 2 match(es). Installing ...
28/02/2015 11:58:07,011 | INFO | > Installed 2 hook(s).
28/02/2015 11:58:16,380 | INFO | Redirecting 'CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 24AB144C)' ...
28/02/2015 11:58:16,428 | INFO | Redirecting 'D3D11CreateDeviceAndSwapChain(00F4DF70, 0, 00000000, 0, 00000000, 0, 7, 24AB145C, 009CF3A8, 009CF3A4, 24AB14A0, 009CF3AC)' ...
28/02/2015 11:58:16,638 | INFO | Redirecting 'CreateDXGIFactory1({770AAE78-F26F-4DBA-A829-253C83D1B387}, 009CF350)' ...
28/02/2015 11:58:16,639 | INFO | Redirecting 'IDXGIFactory::CreateSwapChain(00F72748, 27085688, 24AB145C, 009CF3A8)' ...
28/02/2015 11:58:16,641 | WARN | > 'IDXGIFactory::CreateSwapChain' failed with 'DXGI_ERROR_INVALID_CALL'!
28/02/2015 11:58:16,641 | WARN | Reference count for 'IDXGIDevice' object 2711F360 (1) is inconsistent.

GPU: GV-N690D5-4GD-B (GTX 690)
nVidia Drivers: 347.25
CPU: Intel i7 3960x @3.3 GHz
Motherboard: Asus Rampage IV Extreme (1404 rev BIOS version)
OS: Win 7 64bit with all updates installed

P.S. I mention I do not have Platform Update for Windows 7 x64-Edition (KB2670838) installed because I use IE9.
Last Edit: 1 year 9 months ago by zombkiller.
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1384
What happens if you use plain ReShade without any shaders (remove/rename the ReShade.fx/Sweet.fx file)?
Cheers, crosire =)
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #3

crosire wrote:
What happens if you use plain ReShade without any shaders (remove/rename the ReShade.fx/Sweet.fx file)?

I haven't tried...
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #4

I just downloaded Reshade today to use with Arma III, all I did was run the executable in the zip and point it at my arma3.exe, it said it was successful, I got the beta warning on startup, but not much further - the game crashes 4/4 times so far, so that is my experience with plane reshade without shaders(unless I am missing something).

Hopefully this can be resolved, Reshade looks amazing.

Edit:

I removed all files, reinstalled, and this time moved the sweet.fx file out of the folder to try it 'plain'. Same result; black screen until i click a button, screen turns white and i get to end task or wait for the program to respond, which it does not recover.

Edit:
I have just attempted a manual install, same issues:

Warning: Spoiler! [ Click to expand ]


I, for argument's sake also tried the 64bit.dll in lieu of the 32bit, the game ran, but the shaders were not working.

Warning: Spoiler! [ Click to expand ]
Last Edit: 1 year 9 months ago by Psilocybin.
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #5

Hey, this is my preset; cool.

Anyways I think a lot of people might be having problems because I have the 0.13.1 Reshade .dll packaged together in my .Zip file people are downloading.
This was because I was having crashing issues with 0.14.0, and 0.13.1 I had no issues. Now maybe what wasn't causing problems for me. Is causing issues for others.

I think i'm going to package together 0.15.0 with my preset just in case it is the 0.13.1 .dll causing problems. Hopefully that solves the problems people are having.
I'm always learning.
Last Edit: 1 year 9 months ago by Constantine PC.
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #6

Okay, actually I got to testing 0.15.0 with Arma 3 and I'm having crashing issues with it.
It happens upon game launch and all I get is this in the dxgi.txt:

Warning: Spoiler! [ Click to expand ]


And that's all it says, the game crashes to desktop upon trying to click into the game window with a simple "Arma 3 has stopped responding message".
This is the exact same problem I was having with 0.14.0. Now this doesn't happen every time either, it's a random occurrence. It can boot fine 3-4 times and the fifth time will give me a crash. Upon switching back to 0.13.1, everything works just fine.

I'm just going to package 0.13.1, 0.14.0 and 0.15.0 together to give people options in case one is causing problems.
I'm always learning.
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #7

Care to share your working link?
The administrator has disabled public write access.

ArmA 3 Crash 1 year 9 months ago #8

Constantine PC wrote:
Okay, actually I got to testing 0.15.0 with Arma 3 and I'm having crashing issues with it.
It happens upon game launch and all I get is this in the dxgi.txt:

Warning: Spoiler! [ Click to expand ]


And that's all it says, the game crashes to desktop upon trying to click into the game window with a simple "Arma 3 has stopped responding message".
This is the exact same problem I was having with 0.14.0. Now this doesn't happen every time either, it's a random occurrence. It can boot fine 3-4 times and the fifth time will give me a crash. Upon switching back to 0.13.1, everything works just fine.

I'm just going to package 0.13.1, 0.14.0 and 0.15.0 together to give people options in case one is causing problems.

I have the exact issue(s) with 0.14.0 and 0.15.0. I don't know what might be the cause...but there's always a little light at the end of the tunnel :)
The administrator has disabled public write access.