Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 11 months ago #1

Hello!

There's a problem when using ReShade (tested with latest 3.0.5 version) with Watch_Dogs 2: ReShade works as it should, but it seems to trigger the anti-cheat software the game uses (EasyAntiCheat), and so I cannot play with other players anymore. The game says that I must install EasyAntiCheat to play coop or PvP (it's weird, because the software is already installed, but that must be a bug caused by ReShade). When I uninstall ReShade, I can use all online functions without problems again.

I don't think ReShade will be updated to fix that, as it would involve messing with EasyAntiCheat's functions, and could result in a ban in Watch_Dogs 2, or worse (Ubi account ban). :unsure:

So, I just wanted to warn users that it is not advised to use ReShade with this game, if you plan to use all online functions.

EDIT : Last patch fixes this problem, now you can enjoy WD2 SP & MP without trouble. :)
Last Edit: 1 year 11 months ago by Dr4Wm4N. Reason: Solved
The administrator has disabled public write access.

Watch_Dogs 2: EasyAnticheat and ReShade problem 1 year 11 months ago #2

How did you even get reshade working with WD2?

I'm using latest reshade & the game loads into title menu, but when I load the save game it crashes to desktop.

When I uninstall reeshade it works perfectly. I have deactivated all overlays, etc & still no cigar....
The administrator has disabled public write access.

Watch_Dogs 2: EasyAnticheat and ReShade problem 1 year 11 months ago #3

badjz wrote:
How did you even get reshade working with WD2?

I'm using latest reshade & the game loads into title menu, but when I load the save game it crashes to desktop.

When I uninstall reeshade it works perfectly. I have deactivated all overlays, etc & still no cigar....

Same here , i found disabling SLI, or rolling back the latest geforce drivers fixes it. not the best solution but still..
The administrator has disabled public write access.

Watch_Dogs 2: EasyAnticheat and ReShade problem 1 year 11 months ago #4

I have no clue why it doesn't work for you, since I'm not using any special trick to make it working on my side.

Are you using SLI? If yes, as Aelius Maximus said, you can try disabling it to see if it works for you.
The administrator has disabled public write access.

Watch_Dogs 2: EasyAnticheat and ReShade problem 1 year 11 months ago #5

You can disable EAC by making a shortcut to the .exe and using "-eac_anticheat" in the command line.

Unfortunately that still doesn't fix the crash issue for SLI users using ReShade 3.0 and I also happen to be one of them. Really wish there was a way to avoid disabling SLI and still get it working.
Last Edit: 1 year 11 months ago by Razed.
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 11 months ago #6

Problem fixed by last patch. :)
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 11 months ago #7

So you got it working with SLI?
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 11 months ago #8

I don't have SLI.
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 8 months ago #9

The latest update broke ReShade compatibility for me...
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 6 months ago #10

Has anyone found a solution?
The administrator has disabled public write access.

[SOLVED] Watch_Dogs 2: EasyAnticheat and ReShade 1 year 6 months ago #11

MonarchX wrote:
Has anyone found a solution?

Hello MonarchX,

If you're on Win 10 have you tried switching WatchDogs2.exe to run in Win 8 mode? That worked for me also I'm using nvidia drivers 381.89 with ReShade 3.07 and I've purchased the game through Uplay instead of Steam.
The administrator has disabled public write access.