ReShade Setup.exe issue with 0.15.0

More
5 years 6 months ago #1 by Devla
Hello
I seem to be having an issue with the ReShade Setup.exe file in the latest version 0.15.0

After running the file and clicking "SELECT GAME", pointing it to an EXE, and getting a "SUCCESS" message, I noticed that a d3d9.dll or dxgi.dll file is not being created in the EXE's directory.
However if I select "RUN xxx.exe" from the Reshade Setup, the game loads with SweetFX/Reshade enabled. Just running the EXE on its own runs it without SweetFX/Reshade enabled.

Was this change intentional? In the past, the Setup would properly detect D3D version/32/64/etc and properly copy/rename the reshade32/64.dll files to either d3d9.dll or dxgi.dll.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #2 by kgonepostl
Replied by kgonepostl on topic ReShade Setup.exe issue with 0.15.0
Wait, autodetect works!? Since when!? i've always found it buggy as hell!

Edit:
Through my very limited testing I noticed that it detects dx9 just fine, but it failed every time detecting dx10/11 games. I'm using version 15.0
Last edit: 5 years 6 months ago by kgonepostl.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #3 by crosire
Replied by crosire on topic ReShade Setup.exe issue with 0.15.0
I didn't touch the ReShade setup tool for quite a while. It has been the same for the last 5 or more versions.
You are describing something impossible. Are you sure you are choosing the same executable you are executing?
Last edit: 5 years 6 months ago by crosire.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #4 by Bishi
Replied by Bishi on topic ReShade Setup.exe issue with 0.15.0
Could this issue be something as simple as the process lacking the elevation to copy the file?

Please Log in or Create an account to join the conversation.