[BUG] ReShade & Second Life

  • Posts: 6
3 years 7 months ago - 3 years 3 months ago #1 by Curgus
First things first, I am sorry if this turns out to be a duplicate post of what other people have had... so, reshade 3.0 when used with SL I have noticed not all functions work (RBM & MXAO) along with shadows being controlled by camera angles and are upside down

P.S. it also hides any huds I have within SL and I cannot save presets.

Please Log in or Create an account to join the conversation.

  • Posts: 6
3 years 6 months ago #2 by Curgus
2 weeks and still no response Q~Q

Please Log in or Create an account to join the conversation.

  • Posts: 58
3 years 6 months ago #3 by Exilium
Depth buffer effects not work in online games I think, so, forget it.

Please Log in or Create an account to join the conversation.

  • Posts: 6
3 years 4 months ago #4 by Curgus

Exilium wrote: Depth buffer effects not work in online games I think, so, forget it.


Sorry this took so long to reply to, I have been busy with RL things and totally forgot about the thread... but anyways that isn't necessarily true. from my testing reshade works in online games too. but I would LOVE to see ReShade working fully with second life without it magically hiding my in-world HUDS from the screen.

Please Log in or Create an account to join the conversation.

  • Posts: 6
3 years 3 months ago #5 by Curgus
So, crosire... I'd love to hear a response from you on this matter considering another user on the forums have had similar issues (Dessie66) and got no response either

Please Log in or Create an account to join the conversation.

  • Posts: 3750
3 years 3 months ago #6 by crosire
The OpenGL renderer of ReShade has some bugs and since Second Life renders with OpenGL, strange things can happen.

Please Log in or Create an account to join the conversation.

  • Posts: 6
3 years 3 months ago #7 by Curgus
So is there no way around the strange happenings or fixes for them? :(

Please Log in or Create an account to join the conversation.

  • Posts: 3750
3 years 3 months ago #8 by crosire
Not in the moment, no.

Please Log in or Create an account to join the conversation.

  • Posts: 144
3 years 3 months ago #9 by Insomnia

crosire wrote: The OpenGL renderer of ReShade has some bugs and since Second Life renders with OpenGL, strange things can happen.


True. In Unity, ReShade have access to the depth buffer but depth effects have a tendency to fall behind in the rendering, so for example MXAO will start to miss its target with several frames when spinning the camera.

Please Log in or Create an account to join the conversation.

  • Posts: 2
3 years 3 weeks ago #10 by Mishka
There is a pretty simple fix for all this (at least on Nvidia....ymmv on AMD) is to simply download and use Reshade 2.0 or below, all shaders work fine, it doesnt hide any of your HUDS and works flawlessly ie. shadows render correctly etc.

Please Log in or Create an account to join the conversation.