[SOLVED] Rise of the Tomb Raider Reshade 3.0.6 crash

More
4 years 3 months ago - 4 years 3 months ago #1 by Stefans02
I am trying to get Reshade 3.0.6 AND 3.0.0 working in ROTTR (Rise of the Tomb Raider), but both of them don't want to work.

Reshade 3.0.0 just simply crashes when I start up the game and starts loading the effects. When I delete dxgi.ini the game works but then the effects won't load ofcourse.

In Reshade 3.0.6 the game actually starts and I can start up Reshade ingame. I can start the tutorial, but before I go to the ''changing variables'' part it crashes my game. So when I press continue when I see the effect toggle part the game crashes. And when I restart the game and try to open up Reshade again it instantly crashes. After a reïnstall the game/Reshade works again. But triggers the same problem every time.

Now I found out when I put Reshade into Performance Mode it actually keeps working. And I can toggle/untoggle stuff, and it doesn't crash. But I am mainly using it for screenshots and I need the DoF functioning/adjustable. So I basically need the Configuration Mode. But when I put it back to Configuration Mode and press the ''Home'' tab the game crashes again, and from there I got the same problem.

So is there something I am doing wrong? Or is it just some weird bug? Weird part is a while ago when I played ROTTR with Reshade it worked after a while of trying to making it work. Maybe I forgot something I did last time to make it work, I have no clue. Because back then I was figuring out between different Reshade versions too. So I did A LOT then to make it work..

So if someone could help me with this issue that would be great and thanks in advance.

Greetings,
Stefan.
Last edit: 4 years 3 months ago by Stefans02.

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #2 by Martigen
Replied by Martigen on topic Rise of the Tomb Raider Reshade 3.0.6 crash
Stranger things have happened, but try renaming it to d3d11.dll . Both this and dxgi.dll will load, but some games sometimes prefer one over the other. If it still happens, it's likely a bug with Reshade. I'm about to set up Reshade with ROTTR myself soon so will report back if it's working for me.

Edit: Ok just setup 3.06 in ROTTR, and you won't be happy to hear I had no troubles :) In both main menu and first scene on the mountain top Reshade ran fine in both Performance and Configuration mode. I enabled about 7 shaders including testing some DOF ones, and it all seems fine on this end.

About the only thing that might be different is I set up all my games with a pre-defined stock profile that uses a global shader repository instead of shaders in each game directory. Maybe clear your configs and start again? I really doubt it's this, but here's my 'dxgi.ini' file that I copy across with the Reshade dlls and re-name as required when I install to a game:

Warning: Spoiler!

It's really basic though it does include a max quality preprocessor setting for FXAA.

I love that you can separate repositories too, as you can see I have PirateKitty's shaders installed to a different dir so I can update/include those indepdently but still have them loaded along with stock shaders.
Last edit: 4 years 3 months ago by Martigen.
The following user(s) said Thank You: Stefans02

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #3 by Stefans02
Replied by Stefans02 on topic Rise of the Tomb Raider Reshade 3.0.6 crash
Yes, I got the name change tip from a friend also and that worked! Changed it to d3d11.dll and .ini and that fixed it for me, and I am a very happy man again.

I knew it was something with those files, because I had them working before. And I knew I did something with the files to make them work.

Thanks for the help though!
Last edit: 4 years 3 months ago by Stefans02.

Please Log in or Create an account to join the conversation.